RoonARC and AT&T Pace 5268AC still not connecting

Roon Core Machine

Dell studioXPS desktop running Windows 10 Home
i7 CPU 975 @3.33GHz, 3343 Mhz 4 cores, 8 logical processors
12 GB memory

Networking Gear & Setup Details

  1. Who is your internet service provider?
    AT&T fiber (U-verse) 1Gb

  2. Please list the make and model of your modem and router?
    Pace 5268AC

  3. Do you have any additional network hardware, like additional routers or managed switches?
    Linksys 03991 router downstream of the Pace

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

The Dell is hard-wired to the Pace router and also connects wirelessly to the Linksys via wi-fi
There are numerous devices connected to both the Pace and the Linksys, some wired and some wireless, including additional PCs, unmanaged switches, a TV, and a Squeezebox. There are also many USB devices (drives, DACs, printers) connected that are either wired or wireless.

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

I began with a different connection scheme, but RoonARC reported with a Multiple NAT error. So, I simplified the path so that the Roon Core machine is directly connected by ethernet to the Pace. This has eliminated the Multiple NAT error.

I have tried port forwarding using various instructions in this discussion, and ended up creating a rule that incorporates both TCP and UDP on port 55000. Here is what I get from ARC:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I am not comfortable with these processes, so I cannot work through this alone and I hardly understand most of what other users have posted to get ARC to work. I will certainly not go the DMZ route as the security of my system and data is FAR MORE IMPORTANT to me than my making a RoonARC connection. Still, I would like to be able to utilize this new feature, which - I believe - is a great step forward.

When creating the rule, I used the Roon Core IP that is listed in the RoonARC window, Is that correct? I have verified that it is the same address as the computer’s…

I should probably also mention that my computers are also connected to the Linksys router wirelessly, so that I can access what is connected on both the Pace (Wired) and the Linksys (wireless, with a different IP address) routers. I believe that this has made it possible for RoonARC to avoid the multiple NAT error. - but it may be pertinent to why it still cannot access the Roon Core.

I visited some friends this past week and inadvertently fell into their swimming pool. I saturated my phone, my wireless earbuds, and my wallet. Trying to get RoonARC to work has left me with the very same feeling. I hope you can help.

@Henry_Grillo, I have a similar network (Pace gateway and ASUS router), but a different configuration. I connect my ASUS router to my Pace gateway, and then use my ASUS and an additional ASUS mesh device to serve all of my local home traffic, using only the ASUS Ethernet and WiFi configuration I created (I disabled the Pace’s WiFi).

To make ARC work, I set up a port forwarding rule on the Pace that points to my ASUS router, and an identical port forwarding rule on my ASUS router that points to my Roon Core. I agree, do not go the DMZ route on anything.

Is your Linksys router configured as a router or is it bridge mode so all DHCP is handled by the Pace (i.e., how may subnets or different IP addressing schemes do you have)? My recommendation is that all Roon devices (Core, Remotes, and Endpoints) all need to be served by the same single router, and per Roon’s requirements, the identical subnet. Is this possible?

Hi Robert,

Thanks for the reply. I’ll do my best to answer your excellent questions. I try to keep all the Roon devices on the same router (the Pace), but some of it cannot be hard-wired - so I connect it to the Pace with wi-fi. It has worked reliably for me, but it may be an issue for ARC

I left the two routers to run on independently (not bridged). The IP address of the AT&T router is in range, and the Roon Core is also in that domain… The Linksys IP address is in the range (it is downstream of the Pace and gets its ethernet connection from the Pace), as do all the things that connect to it. I have been able to run Roon on my desktop through the wired connection and still communicate with anything that is running through the Linksys (including endpoints) via a wi-fi connection. I thought that was a clever solution that avoided bridging routers (I tried bridging with both routers but got unacceptable results), but maybe it is the reason that things are not working with ARC.

I really know very little about how networks work, and I am a bit hesitant to mess around with it. The last time I did something like that, it took me a week to put it all back to rights.

A little knowledge is a dangerous thing. I am less dangerous with a little outside help :slight_smile:

Henry, not sure what advice I can provide. Maybe one question is whether your Pace WiFi is on, and if it shares the same WiFi access point names as the Linksys system? If not, maybe think about connecting your Roon endpoints and Remotes that cannot be hardwired directly to the Pace using the Pace’s WiFi. If the Pace and Linksys share the same WiFi access point names, maybe create separate ones for each and follow the first idea.

Ths may cause some interference in your WiFi networks, but if everything having to do with Roon can be connected only to the Pace (or alternately only to the Linksys), then a port forwarding set of rules can be created that should enable ARC.

To start you really should either put the pace in dmz+ mode and use the stateful firewall in the Linksys or put the Linksys in bridge mode.

I will give that another shot. I have read a great deal in these discussions about rebooting everything each time you make a change. Do you support that?

UPDATE - Linksys is in bridge mode. I have rebooted everything. Still getting the same error message:{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Hey @Henry_Grillo,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

Who is your internet service provider and what is your geographic region?
Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

I’ll be on standby for your reply :pray:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.