RoonServer didn't add Music from local Folders on NAS

RoonServer installed on TS-x53D from AppStore. Installed on SSD. Adding Folder “RoonData” with 4 Subfolders and 1,6TB of Music din’d work, trying to delete and re-enable the music folder din’t work too.

QNAP-Systemversion 5.0.0. 1858

So no way using Roon as Server on QNAP anymore? Installing Roon on M1Pro Mac worked, using the NAS-Folders from there worked flawlessly as before, but i want the server on the NAS…

Could someone Help?

TIA,

– Bernd

Hi Bernd,
did you already activate the new folder under settings / storage locations in your Roon software?

Hi Edwin,

sure, i choose the RoonData-Folder and normally it should begin to read the Musicfiles, but it does nothing. Is there something new i have to activate first? This is how it looks:

I can do what i want but Roon did not load my musicfiles. If i choose my Qobuz Account it reads those, so Qobuz works, but not my local files.

This thread has answers. Shortly: Check that you have granted guest access rights to your Roon folder and music library folder.

Thanks! All Rights are granted, but didn’t help.

I have no music library folder, have disabled all QNAP-related multimedia stuff bc i don’t need this, i use PLEX and Roon, thats all.

OK, i will read this thread maybe i find more…

Do you have Roon database in the same folder as music libraries? Try to have them in separate folders.

You describe in your first post that you tried to add 1,6tb of music and now you also say that you don’t have library folders. I’m confused?

Also point the music library folders separately in Roon settings. It’s not enough to just add that root folder of RoonData.

Maybe something with the automatic re scan interval ? Or did you already try to force manually a re scan ?

Thanks @patouskii and @Georg_Huber i am a longtime Roon-User, changing Platforms often, so i have my Musicfiles in a different folder then the serverfiles, sure. I tried scanning and re-scanning the folders, deleting the folders and re-adding the folders. I deleted roon-server for qnap and re-installed it, i also did the update from the server-page, all to no avail. Added a Music folder from a different volume of the nas, all to no success, the musicfiles will not be scanned and so i can not use roon-server from my qnap as planned.

Now it’s no problem to use my M1 Macbook as Roon-Server and pointing it to the same files on the NAS where they all get scanned without any problems. But i don’t want to use my MacBook Pro as server because it is often not in use or closed, turned off, whatever and then i didn’t have access to my Roon Music. Annoying to say the least. If there is no solution then i try using roon-server in a container or vm on this not so powerful NAS or i have to buy a new Hardware just for Roon-Server (which is always the best solution, i know)…

There are some problems with local folders on QNAP at the moment. You can read about it in the thread I linked before. Roon knows this and are investigating the problem.

Workaraounds are giving guest access rights to music library and roon folders and if that don’t work, you can add the music folders as network share. That should work always but usually network share folders don’t automatically scan new music you add to the folder so you need to manually rescan every time you add music.

yes, the only solution that have worked for me was adding a smb share, this might be better then a container or vm. So at least a workaround until the problem is fixed, thanks for all the help.

So I had this problem initially, adding guest access resolved the problem.

Now though, roon isn’t showing all my music. Browsed to an album and all the tracks showed “unavailable”, even though the tracks are still on the disk.

I went to the storage menu under setting, I have 3 folders shared. They all show X amount of tracks, though I realized one was showing thousands less than what it should be.
I forced a rescan and it scanned 100,000 more tracks than were imported, however after the scan, it did not import any of the missing tracks.

Coles notes - I’s missing 30% of my library, even though the tracks are on the drives and all guest access is enabled.

I think I am having the same issue. The group of my music folder is everyone. And owner, group, other have read, write, execute permissions already.

Actually, Roon can see my local music folder but it doesn’t add any music in that folder to the library.

I added the guest access right according to this QNAP - Not Showing Local Folders Anymore [See Staff Post - Guest Access Temporarily Resolves - Ongoing Investigation] - #184 by Sevenfeet. But that doesn’t help either.