RoonServer on Synology does not start automatically after reboot of the NAS (Solved: exFAT filesystem)

Hi all,
Newbie her. Installed Roon on my DS218+, works like a charm, update to 1.3 went on the fly so I am very happy. Have identified all my albums and that works great as well.

I do have a problem though: I restart my NAS every night and Roon does not start up automatically. Is there a way to fix that? Preferably without losing all my album identifications (if I would have to reinstall).


Hi @Jeroen_Top;
I just checked this on my Synology device and it was still running after a reboot of the NAS.
When this happens the next time, can you open the log file and make a screenshot of that content before starting RoonServer manually again?

Hi, thanks for getting back to me.

The error log says:
ERROR: Shared folder “RoonServer” not found.

My Roon library is on a SSD at advised.
Looking at the err msg, it looks like my SSD starts up slower than Roon, could I fix that some way?

Thanks, Jeroen

I have to investigate a little bit and try to reproduce this on my system.
I will let you know when I find out something.

Can you tell me the filesystem of your external SSD (like ext3, ext4, exFAT etc…)?

It is formatted exfat (according to my Synology)
KR, Jeroen

Hi Jeroen,
I just had time to test a little bit with external volumes and different filesystems. Even though I can’t say for sure I am assuming that this behaviour is caused by the exFat filesystem.

I tried external storage with Fat32 and ext4 filesystemss. Both seem to work and do not prevent RoonServer to start up.
I then created an exfat formated drive. I could not mount it without buying the Synology exfat plugin:

So, as exfat seems not be implemented on system level and is loaded by a package during launch, I am guessing this will cause a delay in the external storage mount.

Is exfat essential for your workflow? Otherwise I’d recommend to initialise your external disk with an ext4 filesystem. (Make a backup of your database first!)

Hi Christopher,

I backed up my database, formatted my disk, restored my database, rebooted and everything is working great!
Learned something today, thanks for your help and knowledge!

Kind regards, Jeroen

1 Like

Hello, I have exactly the same symptoms as Jeroen. Similar configuration NAS + USB-SSD.
I found an inconvenient work around that is to go in Synology and start the “Roon Server” manually.
The difference with Jeroen is that the SSD is already formated for ext4.
I am new to Roon my system worked fine for two weeks. Probably until I upgraded the Synology RAM from 2 to 6 GB.
Upgrading was smooth and easy!
Crieke will ask the Log view of the “Roon Server”.
But I cannot see it. When I go to installed packages I find no Log entry!
Thank you. Jacques
PS: I will be absent from this site next week.(starting Monday 17).

Jacques, you may want to start a new thread - this one is marked as solved in the title and you may not get as many people looking at your problem as you could.