Root privileges to delete "roonserver" folder

I bought a nuc and installed roonserver for linux (easy installer) but I got stuck … @support

I want to make sure I keep all edits I made in my library. I read that I need to copy the original Roonserver folder from the mac over to /var/roon/ on the nuc. The problem is that I get an error when I try to trash the Roonfolder that’s present on the nuc. It seems I need root privileges?? What are these?

Also I already tried adding a usb drive that I could share over my network but here I also run into permission issues… I’m unable to access the drive from my mac (using connect to server in finder) The drive is only accessible from within Ubuntu.

Is there proper "walk trough " that I can follow stating all the steps needed to successfully migrate?

Any help appreciated :blush:

If you recall the Roon Linux installation instructions, there was a step like

sudo ./

The sudo command gives root privileges to the command it takes as an argument (after you type the appropriate password when sudo requests it). So, to remove the RoonServer directory (aka folder), you should type (be careful, this really gets rid of everything in that directory)

sudo rm -rf /var/roon/RoonServer

No idea about your usb drive issue.

1 Like

Thanks that worked !
Unfortunaly even though I replaced the roonserver folder with my original all edits I’ve made are gone… Strange

edit @support I seem to have 2 roonserver folders in var now??
the second one was created when I restarted roonserver. Roon uses the newly created one and not the one I copied over from Mac OS. So all my edits are gone! please help

Hi @stevev1,

Linux is case sensitive, the folder that is created after the restart has the correct casing.
The path should be ‘/var/roon/RoonServer’ and not ‘/var/roon/roonserver’.

1 Like

Can’t believe I overlooked that :slight_smile:thanks