Ropiee and 2.4/5 wireless network issue

I have Roon running on PC with wireless network on 5 GHz, using Amplifi MESH network and Bluesound Node 2 in same 5 GHz wireless network and I can remotely control Roon with iPad in 5 Ghz network.

Would like to use RoPiee for control but the Raspberry 3 supports only 2.4 Ghz network.

Installing RoPiee goes well and otherwise seems to be working but can not find Roon in the network, of course most likely because of the 2.4 vs 5 Ghz network.

Would not like to change all systems to 2.4 Ghz - is there any way to get RoPiee in 2.4 Ghz wireless to see Roon in 5 Ghz wireless?

Thank you very much in advance for comment and advice

Is there any way to get

The Raspberry Pi 3 model B+ and the Raspberry Pi 4 model B both have 2.4GHz / 5.0 GHz IEEE 802.11.b/g/n/ac wireless LAN.

Thank you, unfortunately the model I have is the Pi 3 B (without plus) and it has only 2.4 Ghz wireless. I would like to use that model for Ropiee as I have it already and would not like to purchase a new one.

Not a financial issue but a technical challenge that I would like to solve - if at all possible

Hi Jan, this is not possible with the RPi that you have.

Ok, I understand, can solve it of course by getting a 5 GHz model.

However just out of curiosity, any way to solve the issue from the network side ie any way to modify the network so that Roon - connected devices could see each others from 2.4 and 5 Ghz or even from fixed line?

I using the home network with consumer network products so can be impossible but as said interested in checking if there are any workarounds

You should be able to have 2.4 talk to anything on the network as long as its not using a differnet subnet. I have Unifi AC access points and I run a 2.4ghz and a seperate 5ghz ssid and they all talk to each other happily so I would say this is an issue with you network configuration. I have 3 x Ropiees and they all work on either band and find my core.

Thank you, I have had the same feeling that it must be something in the network config. Originally I had the Roon server in wireless and Bluesound wired and there were always connectivity issues. The connectivity issues disappeared when I moved Bluesound to wireless with same 5 Ghz.

The original network setup is the standard setup, no changes except of course the pw and SSID (which are the same for both 2.4 and 5 Ghz).

Any ideas what to look for in the network configuration or subnet setup?

Hello @Jan_Melart,

I looked through your router manual, and the only things that come to mind are a) are you using the 2.4 guest network to connect to and b) have you enabled any of the other protocols that might be interfering with Roon?

As a test, could you plug the Pi directly into one of the LAN ports and test that configuration?

Hello and thank you for the reply. I have disabled guest network at the moment and I have not enabled any other protocols. Everything works fine if I use 5 Ghz (Bluesound, PC, Mac, iPad, iPhone, Android tablet); however what I noticed earlier was that fixed line Bluesoud + wireless PC/Roon did not work too well, Bluesound did not find Roon easily in that combination but required several re-starts.

I used the LAN ports to install and download Ropiee but could not find Roon with fixed line or 2.4 Ghz network.

Tested also with Raspberry 4 (with 5 Ghz capabilities) and Roon and Ropiee worked in that combination.

I can of course start using model 4 but would like to solve the 2.4 Ghz mystery, just being curious

This seems like a networking problem. I’d try the standard advice of powering down everything and restarting from the core out. Then, I’d contact AmpliFi to ask whether anything is blocked internally. Maybe there are logs they could look at?