Ropiee failes to start (first initializing, now only wifi)

I have a couple of Ropieee endpoints, and they all are rock-solid for the past year.
Suddenly, one of my endpoints failed and kept stating ‘initializing’ a couple of days ago. I think the sd-card failed because it didn’t showed up in windows when I inserted it in my laptop. I tried a second sd-card that did immediately showed up and I reflashed that sd-card with a new image of Ropiee that a just downloaded.
But now it keeps booting into wifi config. So the Pi is wired and I see it recieves an IP from the router. When I surf to that Ip, it keeps asking for wifi-setup. But I don’t want to setup the wifi.
Also, no networks show up in the dropdown. So even if I want to configure it to be able to move on, I’m stuck at the ‘Welcome to RoPieee WiFi Setup’ screen.
How can I continue to setup this Riopeee endpoint?
When booting the Pi, nothing is connected to it (so dac is disconnected), only power and LAN.
What are my options?
Kind regards,

That’s strange.

The AP is only activated if the unit does not have internet access during installation.
Could that be the case? It get’s an IP address but does not have access to the internet?

Hi Harry,
Thank you very much for your help.
I connected the device directly to my router for the first boot after flashing the sd-card and it worked using the wired connection. Then I placed it back at my hifi-rack and it still works using the same cable and connection. Strange but the better.

Another issue I run into now, is that the hostname isn’t changing. I changed its ‘hostname’ under ‘System’ but it doens’t change. So in the ‘devices’-tab, it still states ‘Ropieee’.
As you can see below, the hostname is correct in the header of the page below the logo.

I’m also unable to reboot the device using the webinterface. It just doesnt happen when I confirm the reboot. So I have to manualy decouple its power supply everytime I want to make a change.
Am I doing something wrong here?

Can you first update unit? And see if that makes a difference?

How do I trigger an update?
All my Ropieee endpoints have always been updated using a notificationbar above the web-interface.
But the device I’m reinstallling and talking about doesn’t has the notificationbar.
I tried ‘reinstall roon bridge’, wich it did, but nothing changed.
The endpoint actually works fine as a Roon endpoint since I reinstalled it.
It’s just like it doesn’t ‘register’ all the changes I’m trying to make in the webinterface.
I reflashed the sd-card several times since this endpoint crashed a month ago.
It’s also like the device doesn’t have internet or network acces to make its changes, but then why is the webinterface aviable and endpoint working. Because it used to have a fixed IP, but I’m also unable to use that option again (If I click the ‘more info’ label in the network settings, It actually says the right IP and ‘static’). it says it saves the settings, but it doesn’t behave like that.

UPDATE: I took the device back from the hifi-rack and reconnected it directly to the router, which was also necessary to be able to do the initial installation. After a while it gave me the notification bar to update. So now I’m updating the device. This confirms my initial thoughts that the device thinks it doesn’t have internet at its fixed spot in the hifirack. To be clear, nothing changed at the networkside of the hifirack, and all the other devices connected to the internet up there work fine.

@spockfish I’m having the same issues again after last update, but now with another endpoint.

it had disappeared back in the network view after the last update. I disassembled the pi and connected it back to my desk via hdmi. This is how I noticed that after a reboot it kept getting stuck at ‘connecting to internet’. I connected it to the cable and rebooted, that way the update went through. But when I reboot the pi now I can’t get into the GUI. Via the ip it gets via LAN I get ‘connection refused’ and when I restart it via wifi it “seems” to start up correctly, but after full boot it is nowhere to be found. So now I have nowhere to go.

The issues always start the same way: update activated over wifi, device crashed and no longer connects to wifi.

I tried everything I know this morning, but am unable to recover this endpoint. Cannot connect using LAN now (connection refused), and cannot connect using WiFi (won’t connect). I leave the Pi at my desk now, so I can follow-up any instruction.

Meanwhile, I disassembled the endpoint and reflashed the sd card to play music again.
After a reboot and reinstall everything works again.

But so still no clarity why they regularly hang after an update and need a reinstall.