Ropiee won't show up in Roon audio settings


I am having issues setting up my Ropiee device. This is my setup:

iMac with roon core and roon bridge.
Rasberry pi 4b with ropiee installed.
Cambrige audio CXA81 integrated amp with onboard DAC

I am able to connect the mac directly to the amp via USB and it works with Roon recognising the amp.
When I try to connect the amp via Ropiee, Roon bridge recognises the device, but I cannot get it to show up in the settings/audio panel. (this is with everything connected and switched on; roon, ropiee and amp via usb)

My settings on Ropiee are USB audio “on” with no HATs configured.

To eliminate any issues I have tried the following:
-Rebooted and reflashed pi/ropiee many times.
-restarted roon core many times
-connected mac to pi via ethernet to eliminate any wifi issues.
-checked USB power on Pi to make sure USB ports are being powered.

One thing that could conceivably be causing issues is that I am powering the Pi from a power bank. It is rated to output at 3amps, and the Pi works fine with it powered, but it is not powered from the wall. I have also tried to power the Pi directly from the mac and the pi works but wont connect. I am a bit new to USB C and what it can and cannot do.

At this point (barring the power issue) I feel like there must be some sort of incompatibility between Ropiee and the CXA81, is this possible?

Any help is appreciated.

send feedback to Harry here and do this while everything is on. This is done in the Advanced Tab down the bottom. yes its possible…not all DAC’s play nice with Linux but Harry gets on top of these things pretty quick.

1 Like

A couple of reboots of everything might get it going.