RoPieee and B&W A7

Hello Everyone.
I became a Roon User after trying to solve for months the airplay issues… a total waste of time. Now I can’t be happier. Thanks for such a great product!

The problem that I have is this…

I have a B&W A7 speaker in my room connected to my TV via Toslink, and for music I use a chromecast connected to the TV´s HDMI. This setup require the TV to be on to listen to music (from Roon without using airplay). To bypass the chromecast, I purchased a Raspberry 4 hoping to use the A7 USB (it has its own internal DAC) to deliver the music directly and also to be able to use Bluetooth so my wife can use ENDEL or similar apps to fall asleep.

Unfortunately if I use RoPieeeXL, Roon does not see the A7 and the Bluetooth doesn’t work either. Just to try to understand what could be happening I try a linux computer with Roon Bridge installed and it worked. Roon could see the A7. Then found an alternative to RoPieee called VitOS and I gave it a try, again Roon could see the A7 and Play music normally (Almost as Roon converts all 24 bit to 16bit, but the A7 can receive 24/96… but one problem at a time).

So based on this, is there something I can do to RoPieeeXL to allow Roon to see the A7 so I can use it as initially intended?

VitOS only has Roon capability via ethernet. RoPieeeXL has a lot more options.

Any thoughts or comments?

Thank in advance.


Roon won’t “see” your A7, just your Pi running Ropieee.
So you set this up as your zone in Roon and configure Ropieee to output via your A7 as a connected USB DAC - have you done this in Ropieee?
Should work just fine if so, assuming A7 has a standard USB DAC implementation.
Using RopieeeXL your Pi can also act as and endpoint for Airplay and Spotify Connect.

Is your Ropieee is sitting in Settings==>Audio waiting to be Enabled?

Yes. Actually if I connect a dragonfly it shows up in Roon right away but not with the A7. I can see RoPieeeXL as an airplay on Roon.

If I connect the dragonfly it is, With the A7 it does not.

OK, it looks like Ropieee doesn’t have the necessary code in its kernel for that DAC.

@spockfish ?

Hi @Juan_Bonnett ,

Can you send me feedback so I can have a look?
You can find that option on the ‘advanced’ tab. Follow the instructions.


RoPieeeXL just upgraded. Do you want me to do something before sending the file or no need?


I send it anyway… At this point the RoPieee es connected to the A7 via USB.

identifier 8c67955aa8557717



I am glad to report that after the update and reboot of the Pi now it is showing the A7 on Roon.

Thanks for the interest!


1 Like