Ropieee display - can't use wifi

Hi there,
I have ropieee running on a rpi4 and the official rpi display. It works great, but I can’t get the wifi to work. I can log in, I click Network then Wireless, where I see ‘enabling hardware interfaces’, then I commit changes and then it reboots. However it comes back in a wired state and if you click wireless it starts the process again. I am sure i am missing some obvious step. Can anyone advise? Thanks.

Ideally I want to be able to pull the ethernet cable and just go with the wireless.

Just to be clear after it says “enabling hardware interfaces” are you then enabling the WiFi, selecting the interface (after canning for it if needed), entering your Network SSID, and entering the passphrase before hitting the commit changes button?

Also, if you are using the RPi as an endpoint it may not function as well over wireless as it would if it was wired.

Thanks for the reply.

I am not using the rpi as an endpoint, its just for the display.

In terms of the steps, I go ‘network’

hit ‘wireless’

Wifi has been enabled, and often is still enabled from the previous attempt

Then I commit the change, then save and the device will take a moment before wanting to reboot, then it does, but no wifi.

I notice in the wired screen shot it says “static” for the configuration method as opposed to “DHCP”. I am not sure if this may be the issue? Let’s see if @spockfish might be able to help here.

does the “more info” button show it was assigned an IP etc?

Ah yes, I will go and put it back just to try and see if makes a difference.

No difference, from what I could see. I wonder if the wifi is not working, or I have not enabled??? The onboard pi wifi is recognised in the software.

You need to hit the SCAN button to actually first scan for your network and then select your wifi network.

Considering this is an external stick it could very well be that it is not working properly.

Hi Harry - thanks for replying.

What do you mean by ‘external stick’? I thought the wifi was just built into the rpi4?

I have done this, if I look on the wireless settings, an IP is assigned, but I just cant access wirelessly.

Just an update - I usually just get a the “connection has timed out”.

But I did see this once this morning

It makes me think it is the wifi which is malfuntioning.

Yeah. That’s the problem with those pesky Realtek dongles…

Anyways, either get one of the sticks I have (and thus support), get a WiFi bridge or use cable.

Thanks

Do you use a seperate dongle on a rpi4? Which one do you use?

I quite liked the idea of having a screen in a few locations, however I want tham to be wireless to make it easier. Right now its on my desk, so I can use a wire but it does seem to move the unit about a bit!