RoPieee for noobiiiee

I would like to use RoPieee to set up my rpi with digi+ hat as a roon endpoint.

I cant get the file downloaded from the RoPieee web site to burn to the sd card. Ive tried both etcher and windiskmaker.

What am I doing wrong?


So… you have troubles downloading the image?

Ok, used my macbook this morning and this time the burning worked.
I installed the sd card in the rpi reader, the rpi booted, and I can see the
ropieee in the ropieee.local thing. I configured the hat (digi+ pro) and
the ropieee rebooted.

BUT: I still can’t see it in roon.

What do I do?


Ok, that’s good.

To be sure: did you have ethernet connected during installation?

Furthermore, can you go the ‘advanced’ tab of the RoPieee webpage and hit the ‘send feedback’ button?

I can then have a look in the logs.

Just did. Code is c71f7057cdc2cc40


And yes, it has had ethernet connection the whole time.


Ok. I see what the problem is. There was a hick up during installation.

Furthermore I see that the unit is not capable of synchronizing time properly because of DNS resolving issues. Do you have something manually configured in your infrastructure?

Because this is required to work properly.

No I have not done any manual configuration.

All I have done is to unbox a (brand new) rpi and attempt to install
the hifiberry roon image. That didn’t work. Mr David from hifiberry
found out that the hifiberry roon img is faulty and he said it would take
long time to fix. So he suggested that I install RoPieee instead.

Is there a way of un-hicking the installation and fixing the DNS
time thing?



Are you familiair with SSH? Something like Putty?

No clue. I was looking and hoping for a plug-and-play experience.

Anyways, if you tell me what to do, I’ll do it.


Well, that’s the idea with RoPieee.

I’ll create a custom image for you. That takes some time, but I’ll try to finish that today.

I’ll poke you when it is online and you can download it.

That’ll be great. Many thanks.


@jesper_andreasen can you try this one:

Let me know how it goes.

Thanks but still can’t see the ropieee in roon.

Here’s the code



Hi Jesper,

Ok. I know what is going on. I don’t know yet how to fix it yet…

Problem is that for some reason (that I can’t explain), it takes a very long time before your network comes up.
This results in a few processes going down the drain (one of which takes care of pulling in the necessary stuff from Roon).

Let me tinkle a bit. I’ll try to create another image for you. Problem is that I can’t test it, so we have to do it this way.

If your not already done with this then I’m sure we’ll figure it out in the end.

Regards Harry

hi @jesper_andreasen,

Looking further I’m afraid this is not something I can resolve. For your information, the time it takes for the interface to come up is 12 (!) minutes. That’s not normal and indicates there’s something going on in your network.

Can you explain a little bit how your infrastructure looks like? Have you tried to reboot your router?

Thats very kind of you.

I’m still here and will keep going as long as you’re up for it.



Hi Jesper,

Did you saw my other message?
This is an issue with your infrastructure I’m afraid. It takes more 10 minutes to come up, and that’s not good.

It’s also not something I can fix from within the software, so you need to do some investigation in your infrastructure I guess.

Regards Harry

Sorry looks like our messages crossed.

There should be nothing special about my infrastructure.
The router and installation is a standard job from big danish telephone
company and internet provider tdc. I have not tinkered with anything.

I just rebooted the router and it actually came up quite quick.

Fwiw, Ive asked the ropieee to send a new report: fab9e4018cfd7dff.

I can try to get someone capable to look at it all.


When you say it takes 12 mins to come up, what is it that takes all that time?