Ropieee+HiFiBerry DAC2 Pro - Wifi disappears after long idle period

Current build of Roon, running on Ubuntu server. Seems stable… wired to network.
1x Pi4 + HiFiBerry Dac2Pro wired to network, it’s fine. Stable. No problems.
3x Pi4 + HiFiBerry Dac2Pro WIRELESS. Work great for a day or two, and then disappear from Roon. I have to reset the Pi4 to get them to reconnect.

Wireless is 3x Google WIFI Mesh routers, wired to each other. Gigabit wired LAN, fairly new unmanaged gigabit Netgear switches. Wired network is quite stable, as is wifi… excepting this.

I start the wirelessly attached Pi4’s, everything is good, for a day or two. A couple days idle, wife tries to start some music on one of the wireless Pi4’s, it’s not in the list of available zones. Have to reset the Pi4, it comes back… for a day or so.

Current version of Ropieee, all three Pi4’s were bought from Amazon in the last couple of months. Canakit version, not a generic clone. Same model HiFiBerry on each, good quality power supplies…

When this happens, I can still see the wireless Pi4’s in Google Home, and I can launch the Ropieee web interface… the Pi’s are connected to the network, Roon is dropping them, some how. Only the wireless ones… but all three of them. Wired Pi4 never drops.

Any assistance would be appreciated.

1 Like

What happens in the described scenario if you restart on of the Pi’s or restart your Roon server?

1 Like

Restarting the Pi’s ‘fixes’ the problem… Pi’s initialize, and Roon picks them up.

Restarting Roon doesn’t make any difference.

Sorry for the delay in response. Had people over yesterday, wife went to play some music, and the issue happened. Second time in as many weeks. Anyway, I wrote the complaint, reset the Pi’s, and went back to the pool party :smiley:

Another possible contributing factor: Wifey pointed out, while I was resetting Pi’s, that we’d been having power issues. Not uncommon during spring storm season. Short power ‘blinks’… I’m fairly certain that we’d had a short power outage during each of the extended idle periods.

How do the Roon service and the endpoints recognize each other? Is there a broadcast protocol that seeks for a period of time at startup and then stops looking? It’s possible, I suppose, that the RPi’s restarted during the power blink, and came up before the wifi network was back up and running. Would they simply ‘give up’ looking for the server? If so, we may have identified the problem. Why would it be different for a wired ethernet RPi? Server is on a battery (repurposed laptop), so a short power blink wouldn’t take it down… but it would take down the wifi access points, and the wired switches… I suppose the wired switches would probably come back faster than the wifi access points.


1 Like


Same issue here. Running RoPieeeXL v3.113 on a Raspberry Pi 4 Model B Rev 1.4 w/ USB connection to my DAC. After extended idle/non-use time WiFi disappears. Roon cannot see RoPieeeXL and I am unable to access the WEB GUI. I am using internal Pi 4 Wifi with a 3.5a power adapter connected to a battery backup. Server is also on a battery backup, so no unexpected power issues on either end. Relatively small home and router is in close proximity, so WiFi signal is strong. If I reboot the Pi 4 RoPieeeXL will be seen by Roon, I can connect via WEB GUI, and all is good until next time. I have tried piCorePlayer and DietPi with no issues. Really want to use RoPieeeXL for Roon and Spotify.

Oooops. Accidentally sent feedback (which now I know is actually logs). Don’t know if it will help, but… 730f4a1bcb086f03

(The logs were after a reboot since I could not access the WEB GUI via WiFi. If it happens again, I will wire it in and send additional logs.)

Keep up the great work!!!

Again, this morning. Got up, noted that the oven clock was flashing… yup, brief power flicker.

Only my hard wired Pi is online, showing up in Roon.

A simple delay in initializing, preferably configurable, would almost certainly resolve the issue. On power failure, wait X minutes before initializing Roon endpoint.

I note that the RoPieee starter docs show a specific location here to talk RoPieee… I’m going to comment there, as well.

I’ve been having similar issues with a RPi 4 + HiFiBerry Digi and a RPi 4 + HiFiBerry Amp Hat but while running HiFiBerryOS.

Sometimes I can see the web interface and a restart from there makes it reappear in Roon, other times I can’t and have to pull the power to reboot it. Sometimes I can’t see it in Roon or access it via the web interface but can still SSH into the RPi and a reboot on the command line solves things. No real rhyme or reason. The RPi running HiFiBerryOS with a HiFiBerry Hat are the only devices that drop off my network like this.

Up till now I had just put it down to a setting on my network which I hadn’t yet had the time to fully resolve.

Raspberry Pi endpoints

  • Static IP, reserved in my router, not used by any other devices on my network.
  • DNS
  • Same subnet as ROCK
  • HiFiBerry OS (20210531)


  • Static IP, reserved in my router, not used by any other devices on my network
  • Same subnet as endpoints
  • DNS
  • Version 1.8 (build 795) stable


  • Unifi Dream Machine Pro (1.9.3/6.2.2)
  • IGMP Snooping: OFF
  • Multicast DNS: OFF
  • UAP-FlexHD (5.43.23)
  • Signal 90% / -54db (main RPi endpoint)
  • HT20 / AUTO | VHT80 / AUTO
  • Band steering: OFF

I’ve tried setting up the RPi endpoints on their own 2.4Ghz SSID instead of the main 2GHz/5GHz SSID. But that doesn’t seem to have helped.

Am yet to test if fixing the AP to a specific WiFi channel helps, but I have my suspicions that the RPi may be dropping off the network when my UDM/AP’s run an automatic scan for a better channel. Will try fixing the channel to a static value later and see if help, obviously won’t know till I next lose an endpoint from the network.

Realise this is the Ropieee section, but thought it worth posting my findings with HiFiBerryOS as the symptoms were so similar. So wondering if it’s a wider issue with the RPi networking stack (and certain router settings) or a library used by both distros.


I don’t know if this really has anything to do with the situation I am/was having, but disabling ‘Dynamic Audio Power Mgt’ seems to have improved matters with no drop-offs in the last 1-1/2 days. Previously it would drop-off at least once everyday. I am running USB out only, so this setting should not really have mattered in my case. Also, I am not running any type of HAT – just straight out USB to my Schiit Bifrost 2 DAC.

Fingers crossed.

The issue has not reoccurred so I’ll consider it a non-issue for me at this point. Was it coincidence or did disabling ‘Dynamic Audio Power Mgt’ resolve my issue? I’m not sure, but all is good in my Roon World now. :smiley:

1 Like

Quick updater on my post/report.

It’s only been two days since I made the change, so nothing conclusive. But since I fixed the channel on my AP rather than using AUTO the RPi have remained stable and connected. That does suggest that either the RPi endpoints don’t always reconnect properly when the channel is changed or that the RPi doesn’t like using a particular channel.

As an aside changing the channel manually (which causes the wifi to drop and reconnect) doesn’t necessarily stop the RPi reconnecting although sometimes it does which indicates this may be the issue there. Nor is it obvious there’s a particular channel it dislikes, but I haven’t stepped though each one individually to check.

Anyway, hope that is of some help to others stumbling on this post. I’ll report back in a week or so if the fixing of the AP to a static channel has solved things long term.

1 Like

Spoke too soon, it seems. This morning I was not able to connect to Ropieee and Roon did not see the Ropieee zone. I changed the Ropieee / RPi config to use the WiFi 2.4GHz band and SSID as opposed to 5GHz band and SSID. Going to try that before locking down a channel and/or creating a dedicated SSID for the Ropieee / RPi.

It’s really a shame that this not working as well as it should. Ropieee is a wonderful platform and checks all the boxes for me.

Arghh…how annoying,

Not sure if it helps but it’s been 5 days now since I set my 2.4Ghz SSID to a static channel (*) and haven’t had an endpoint drop of my network since. Previously it was happening to one of them every few days.

(*) channel 11 in my case, but that may not be a good channel in your RF environment. I’d run a WiFi scan to see which 2,.4Ghz channels are least congested and go from there.

1 Like

I believe I have confirmed your findings. I changed my router channel selection from AUTO and manually forced a channel change by assigning a static channel. After the channel change, I was unable to access the Ropieee web interface, ping via the assigned/reserved IP, or see the Ropieee/Pi 4 on the list of wireless devices associated with my router WiFi. Needless to say, Roon did not see the associated Zone. I did a power cycle on the Pi 4 and it came up just fine being visible on the network, pingable, and available via Roon. I then forced another channel change just to be sure, and it disappeared from the network and Roon once more. Power cycle and it came back fully online and available.

I do not recall this happening with either DietPi or piCorePlayer, but I’ll have to do some experimentation to make sure. That should help determine if it is something with the Ropieee associated kernel / driver or related to the Pi 4 itself.


Installed a Wireless Extender in my music room and setup a separate wireless 5GHz SSID / Network with a fixed channel. Tied it back to the home network using a 2.4GHz wireless backhaul connection to my home wireless router. I get the best of both worlds – home network router handles finding of optimal channels to combat interference from neighboring networks while the music room extender network remains on a dedicated low interference 5GHz channel selected after scanning for nearby wireless networks. No Pi 4 / Ropieee WiFi drops or disappearing zone in Roon. Ropieee XL, RPi 4 and Roon are all happy at last!!