RoPieee minor drop outs

Running Raspberry pi 4 with HiFiBerry Digi + Pro via WiFi & getting occasional <1 second drop outs that did not happen with Sonos Connect. Sound is better than Sonos, but tiny gaps in playback are annoying. Ethernet is not a viable option, so are there ways to remedy the WiFi problem? Switch to HiFiBerryOS? Anyone, anyone?

Try to change 2ghz to 5ghz or the converse.

Can you send me feedback so I can have a look at what’s going on?


What setting is that?

Are you asking to me about the 2/5ghz settings?

Go the ‘advanced’ tab in the web interface and hit the ‘send feedback’ button.

Oh, I see now that that question was for me.

Just check in what band of your router your Pi is connected: 2,4GHZ or 5GHZ.

That’s why, in my home, some devices goes better on the 2 and others on the 5.

So I think that a very simply trial is to change the band.

If you router choose alone what band to use, not always it choose the right band for the device.

Also, try to change the channel of your wifi. Routers not always choose the better channel.

There are dozens of Android apps that help to choose the right wifi channel.

Just some trials to do when something is wrong on the wifi.

In my case the Pi is on 5Ghz, far from the router but no drops until now.


Sorry for the delay. My Raspberry Pi and HiFiBerry is new, with 3-4 listening sessions of 30-45 minutes each. I use Roon and typically add several tracks to a queue and just play. A few times, the same track (Ten Years Gone on Led Zeppelin’s Physical Graffiti) starts a split second into the beginning. I’ve dragged the track back into the queue and it’s fine the 2nd time through. One other track during another session — I can’t recall what — started to play for a split second and then abandoned, continuing onto the next track. This may be a WiFi issue, but a Sonos Connect, via the same router doesn’t behave this way, and that setup is slightly further away than the Raspberry Pi setup. The HiFiBerry connects to a Schiit Multibit DAC and then to a Rega Ear headphone amp. I would prefer an Ethernet connection, but that is not possible at this time.

Sounds like a weak wifi signalHave you tried a WiFi range extender in the same Room as the RPi

You can dowload some free wifi meter apps to check the signal strength

The other option may be to have an extender and a LAN cable to the RPi

Hi @Greg_Thompson,

Looking at your logs I definitely see drop outs in the logs.
As other suggested, this is typically related to infrastructure issues in your network.

Besides the obvious (“go wired”), which you already stated is not an option, there might be a few other things you can try:

  • go to 2.5G. I can’t se if you’re on 5 or 2.5, but 2.5 has better reach.
  • use an external WiFi to Ethernet bridge. They are fairly cheap, but in many cases have better reception.


My WiFi is set to 2.5 — I tried 5, but that made it worse. I’m now using a WiFi to Ethernet bridge and I can at least get hi-res to play, but I’ve had a few drops. I need to do more listening, but so far, pretty good. I’ve read some Roon forum chatter on powerline adapters, with a mix of opinions. Best solution seems to be cat6 through the wall, buried along the perimeter of the house (one story, which helps) and back through another wall would give me true Ethernet.