RoPieee + Mytek Brooklyn not showing up in Roon

Hello folks,

I started my Roon-journey just a few days age and am still on my free trial.
I am currently using an older NUC running ROCK (so far working flawlessly) and have been using an Allo USBridge Sig with a Mytek Brooklyn DAC+ running RoPieee. This morning RoPieee just didn’t show up in Roon, no matter what I try, it isn’t showing.

I can open RoPieee via my browser and can also access ROCK.
Could this be due to the yesterdays update which I installed before going to bed?

Thank you and stay safe

Hi @Jakob_Tribula,

Can you send me feedback so I can have a look what’s going on?
Go to RoPieee’s webpage and then then ‘advanced’ tab. There’s a button ‘send feedback’.
Hit that one and report the UUID over here.


Hi Harry,
thanks for getting back to me on this. I just send feedback and the UUID is 3faab141eb86368d. Let me know if there is anything else I can do and if I just made some simple mistake :sweat_smile:

Hi Jakob,

I don’t see the DAC in the logs. Is it turned on?
Keep in mind that RoPieee only shows up in Roon when the DAC is connected and powered on.


My bad, forgot that I plugged the DAC straight into the core to get some music going.
Just sent a new log with the Brooklyn turned on and set to USB input.
dbfde8eb5065fc63 is the identifier

1 Like

Maybe an interesting discovery:
When I open Roon on my Laptop and go to the “About” page in the settings the Allo USBridge is actually listed under Roon Bridge (with the correct IP-Address and running Version 1 Build 171) so it seems to at least be seen from the system. It is not showing up on the “Audio” page though.

I just don’t see the device at all.
Nothing that indicates that is connected.

I figured it out, though not 100%. It is working for now though :+1:

The Allo USBridge Sig has 3 external USB ports in total, 2 in the front which are labeled WiFi/BT and 1 in the back which is labeled USB Clean. The one on the back is supposed to have lower noise than the ones on the front and therefore is meant for connecting the USB DAC to the USBridge.
Until Thursday afternoon that worked with Ropieee as it should and I believe after I installed the latest update for the Core it stopped working, though I can’t say that for certain. I have now plugged the Mytek into the left of the two WiFi/BT ports and it showed up instantly in Roon.

I have sent you Feedback on this again Harry: a4f2fb8f52191b44

Thank you for your work!

Today the problem changed yet again:
I was again not able to find the Allo/Mytek Combo as an output in Roon. After rebooting all the devices involved it still didn’t work so I started testing the other USB ports of the Allo and sure enough now the Mytek is only recognized on the right hand port on the front.

I have send feedback again under 75a91c275f7e03d2

Let me know if I can do anything to help narrow down the problem!

I see some reports from the USB controller in the logs. Did some digging and it points to over current. Is it directly connected? or is there a hub in between?

That is strange…
No, the Mytek is directly connected to the Allo via a normal USB cable. Have I fried the Allo’s ports??? :thinking:

I’m not sure if that’s possible. Do you have a Pi lying around by any chance to rule this out?

Shorted or faulty cable maybe

The cable is working fine with the Allo’s right front USB port (at least for now) and has been working for a few months before that (Volumio on the Allo and same Mytek).It also works without a problem when I go out of the NUC-Core and into the Mytek directly.

Is there a way to measure if the USB ports are shorted? I had already opend the Allo but could not see any problem.

I do have a spare Pi3B+ here, Harry. Should I just install RoPieee and try it’s USB ports?

Yeah try a Pi. Curious if it will work.

I finally tested it with the RPi 3:

Aaaand, nothing. I can access Ropieee on the RPi 3 via it’s IP-Address no problem but it refuses to show up in Roon when I connect the Mytek to any of the 4 USB ports. As soon as I plug the USB Cable back into the Allo’s front right port it shows up in Roon. The other two ports are still not working.

Very strange, next stop is probably to contact Allo and ask for their thoughts on this matter i guess.

Edit: I’m also going to borrow a USB cable to rule out a problem with the current one.

Ok few things:

Your installation didn’t completed fully. Did you had the unit connected to the internet during installation? That’s a requirement for RoPieee to be able to install all necessary components.

Secondly I see some ‘unsupported format errors’ and indeed a lot of reconnects from the DAC. Is there a way you can reset your Mytek to factory settings or something like that?


I should really stop doing these things late in the evening… :confused:


It’s working now with the RPi3, can you see any over current from the logs?

These logs look sane. Nothing reported about current problems.