RoPieee not indicated in ROON networked devices

Core Machine (Operating system/System info/Roon build number)

INTEL NUC 8I7 running ROCK operating system trial version license

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router MikroTik RB951Ui-2HnD, NUC and Raspberry PI 3+ connected via LAN.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Audiophonics I-Sabre ES9028Q2M, ALLO KALI, official 7" raspberry display

Description Of Issue

Hi, I having an issue with detecting RoPieee (latest release 2019/10/12) in networked devices of roon core. The core does see RoPieee core extension and I have enabled it. I try to “flush” two different SD (16Gb) cards with same negative result. I able to do all settings in RoPieee web user interface without any problems. I also have tried different browsers to download image and different uncompressed and XZ images without luck.
Right now I running DietPI as roon bridge and it was detected by roon without any issues and plays just fine, but I really would like to use Ropieee as roon bridge because it has display feature which is preferable for my setup. Could anybody assist me with this issue, please?
Thanks!

Hi, @spockfish, I have an identical issue. My RopieeeXL is not presenting itself as a RoonReady endpoint. I have restarted the Pi, restarted the extension and restarted Roon Server in ROCK.
Feedback: 491deee4ebb76406

1 Like

@Serhiy_Dihtenko1 can you send feedback? You can find it on the advanced tab of the web ui.

One more thing: I’ve recently released an update with a new kernel. Unfortunately that introduced an issue with the Audiophonics HAT, so can you please select ‘RPI-DAC’ for now?

Thanks

Hi @Henry_McLeod

Something strange going on: I can’t open the feedback archive as the file is corrupted. Can you try again?

4084b2881b246b97

Give that a go.

@spockfish
The feedback was sent. The ID is 55e8b478de86cc34
As was advised, I have changed a HAT description in ropieee setup from ES9028 to RPI DAC (I2S), the endpoint became visible for roon, audio output is present. I also have volume rotary encoder in my player. In this current setup the remote control of device volume is not available from roon. In DietPi I able to control device volume from roon. The feedback was sent after changes were made.
I appreciate help and hope that bugs will be fixed soon. Donation will be coming soon as well;)

Hi @Serhiy_Dihtenko1,

I’ve pushed out an update (382) that brings back the native drivers for the Audiophonics.
So please, after the update has been applied, configure it again with the Audiophonics instead of the RPI DAC and see what happens.

Thanks

2 Likes

Hello @spockfish I have tried 382 but no improvement unfortunately, roon still can’t detect the endpoint. I have rebooted all devices, extensions in roon is enabled.
Feedback b2b465a454529470 was sent.
I have rebooted all devices.

Yeah the driver reports issues with the hat.
So you need to go back to the RPI-DAC driver I’m afraid.

Yes, the RPI-DAC is working. Is any one else using Audiophonics E9028Q2M dac’s with RoPieee? Could it be the case in ALLO KALI recklocker?

Just to confirm my report was in error. My DAC is now plugged in!

1 Like

I have the same issue and I use E9038Q2M and allo kali with the ES9038Q2M GPIO Adapter and it can’t be found in Roon.

Can you try with the ‘RPI DAC’ HAT?

Sorry, should have mentioned that, that works.