RoPieee not recognized by Roon

I was using RoPieee (Raspberry Pi 2 Model B Rev 1.1, HiFiBerry DAC+, Version 337 ) sucessfully for one year on my Roon Server (build 416, Windows Server 2019). Than I switched RoPieee off for several days and now I am not able to bring it up.

It is neither shown in the audio settings nor in the about page.

Web access to RoPieee is working and I several times restarted Roon server and RoPieee.

I tried to figure out with SSH what is wrong :

**[root@ropieee ~]# aplay -l**
**** List of PLAYBACK Hardware Devices ****
card 1: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
**[root@ropieee ~]# lsusb**
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
**[root@ropieee ~]# ls /proc/asound**
card1  cards  devices  modules  pcm  seq  sndrpihifiberry  timers  version
**[root@ropieee ~]# ls /proc/asound/card1**
id  pcm0p
**[root@ropieee ~]# cat /proc/asound/card1/id**
**[root@ropieee ~]# ls /proc/asound/card1/pcm0p**
info  sub0
**[root@ropieee ~]# cat /proc/asound/card1/pcm0p/info**
card: 1
device: 0
subdevice: 0
stream: PLAYBACK
id: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0
subname: subdevice #0
class: 0
subclass: 0
subdevices_count: 1
subdevices_avail: 1
**[root@ropieee ~]# ls /proc/asound/card1/pcm0p/sub0**
hw_params  info  prealloc  prealloc_max  status  sw_params
**[root@ropieee ~]# cat /proc/asound/card1/pcm0p/sub0/status**

Can somebody help me ??

You could try sending feedback via the Advanced tab, if Harry has time to take a look.

I’d also check for obvious things, like network access between the server and endpoint, or the correct option (your HiFiBerry HAT) on the first tab.


HifiBerry DAC+ Pro is set correct.

Connectivity OK, I used SSH from the server where Roon is running.
I also tried disabling firewall, without success.

I sent feedback - id 9ded8071907b0371

Unfortunately it looks like your filesystem is damaged.
I’m afraid a reflash is the only thing left to resolve this.

Thank you very much for the quick help. It is running now.

Greetings from beautiful Vienna, one of the very few cities where wine is growing inside the city area.

Oh wow! beatiful picture, beatiful city!

Enjoy the wine :wink: