Ropieee Pi 4 WiFi issue?

I use two Pi 4 endpoints with similar Hifiberry HATs, both running Ropieee on WiFi. Two fixed locations but swappable.

I’m frequently seeing variants of the Roon message “Qobuz/file loading slowly” and then tracks skip after playing for a couple of seconds. Unusable often. Both locations, both Pis but one seems worse. No issues with my main system.

WiFi signal strength seems fine for other devices at these locations but is this likely to be WiFi related?

I have the same isue. I need to reboot the Pi to get back to normal. It’s not frequent though.

Had the same issue after upgrading to latest stable. Improving my network somehow fixed it, moved my Orbi to access point only and assigned it a static IP address in my Netgate 3100 box. From being unusable to happening once in 4 weeks. So before buying a WiFi dongle, maybe check your network first.


Just spent hours on my network but no improvement to the Pis. I don’t have the luxury of static IP on offer from my ISP but I’m not sure that’s relevant. Maybe I have to run some CAT cable to both Pis but that’s a massive job; something I wanted to avoid. I’ll try a messy/temporary cable to see if it solves the issue.

Yes, just tried to simplify my network. Assigning static IPs and permanent DHCP leases shouldn’t matter these days (within network, not to ISP). Maybe send Harry some feedback in the Advanced tab.

Just to tie up the thread, Harry suggested a Wi-Fi bridge. I bought a Vonets VAP11G-300. It works well.

While I waited for the bridge to arrive I established that, in my network, the WiFi onboard the Pi is just about OK for 44/16 but nothing above that. With the bridge, everything up to 96/24 is OK.