Ropieee - RaspPi3 & HifiBerryDigi+ no Sound anymore

Hi there,
I am running out of ideas with this problem.

My Pi 3B with Ropieee and a Hifiberry Digi+ Hat ran fine for the last two years, but now I am getting no sound out of it.

Until this evening I was running the core on my Synology NAS, which was absolutely fine, because no DSP Work needed. I reinstalled ropiee a couple of times, via browser and in the end which a new image. Still no sound.
Now I even upgraded to DSM 7 on my NAS, again fresh install on the Rasp Pi: still no sound.

So I really have no clue what is going on.
I can see my Pi in Roon, I can play music with it, but I hear nothing.
the digital inputs of my speaker work so no problem there.

On the Hifiberry neither the optical, nor the RCA digital Output sends anything.

Does anybody of you here, has any idea?



Have you checked on the ropieee web ui to make sure it is up and running with the correct settings?
If so, I would send feedback to @spockfish from the advanced tab in the Ropieee web Ui, maybe it will show something there?

does your roon install on the synology work otherwise? I have seen a few comments going through about DSM7 causing issues over in those threads.

All Settings should be correct and every other endpoint (Ipads, macs,…) is still working correctly with DSM7. no problem there…

My ropieee just stopped working out of the blue a couple of weeks ago.

I think that you need to determine if the problem is due to an issue with the Digi+ hat board. If you have a DAC with a USB input, you could try plugging a USB cable into your Pi and see if the Pi works works via USB. You will need to change the settings in Ropieee to use the USB output to do the test. If you get sound with the USB connection, it is likely that there is a problem with the Digi+ hat.

I would alsop suggest you reseat the HAT (remove it and reinstall again physically)

do send Harry a feedback from the advanced tab tho first…