Ropieee XL airplay icon not showing on MacBook Air

Hi - this isn’t very important, but although I can stream to the Pi 4 from my iOS devices my MacBook Air (Big Sur) doesn’t show the icon in the speaker dropdown? My Sonos and Apple TV are always present, but not Ropieee XL shairport-sync.

Its only because its Proms season over here and I can stream the BBC iplayer feed across to my headphone set-up and watch the program on the device (with virtually no audio lag incidentally! :blush:) and the bigger screen of the MacBook would have been nice!

PS. What’s in this new release my Pi4 Ropieee web page tells me I need a manual download for? It must have been a while ago as I can’t find any major announcements here… but of course they are in order of last posted so who knows? :blush:

RoPieee-NG is a completely new release, and can only be installed afresh with a re-imaged SD card.

This, in standard and XL variants, is the only release available for download now.

Thanks Martin, so does anyone know why my MacBook can’t find Ropieee XL on the RPi4? Is this perhaps a thing Harry (@spockfish) like I say not crucial at all but would be nice :blush:

Post a screenshot of your settings under the Airplay tab.

1 Like

Not much to see Richard? I’m using the Allo DigiOne HAT, nothing has changed, works fine on the iOS devices just not seen by the MacBook Air on Big Sur?

image

I don’t have an answer for you. Has it worked before, or are you trying it for the first time?

If your iOS devices can Airplay to it, then your RoPieeeXL is probably working correctly. Have you rebooted your MacBook Air? Since it involves networking, you could also try restarting your WiFi router.

It is the same on my MacBook Pro late 2011 running High Sierra.
Mac AirPlay (red) doesn’t show RoPieeeXL as AirPlay device as it is audio only, while Mac shows video AirPlay devices like Apple TV.
But, for example, iTunes (green) running on the same MacBook Pro can show RoPieeeXL as AirPlay device.

What about if you drop down the ‘speaker’ toolbar icon Stefano, that’s the one that deals with audio only. The Airplay icon is for screen sharing and video streaming and sometimes doesn’t show audio only devices?

Here is my MacBook airplay screen:

image

And here is my iOS airplay choices:

Maybe @spockfish can throw some light on the matter?

Probably haven’t tried it before, I usually use Roon for music, I only enabled XL in order to stream to the Pi from iplayer on my iPad for watching the proms. Then it occurred to me that the MacBook has a bigger screen, but as we can see no Ropieee to stream to?

@Tim_Woodward

I see that you’re running the old version of RoPieee.

I suggest you upgrade first. This time that means a reflash, because the new version is based on a new architecture.

Thanks

Was thinking along those lines… doing that now…

Thanks Harry :blush:

… RoPieeeXL is there …
image

1 Like

Thank you! Very interesting…

@spockfish

Ok I’ve downloaded, installed and set-up the new RopieeXL (note to self, do not glue Pi4 to underside of hifi rack again with Micro SD card upside down and inaccessible!!! :crazy_face: ) and still no Airplay icon on the MacBook Air (Big Sur 11.6.6 (20G624)). All iOS devices see RoPieeeXL fine… weird?

I’ve turned off and on all network bits and MacBook all works fine, I’ve configured wifi as well, but the MacBook didn’t find RopieeXL on wired ethernet either so…?

Sent feedback just in case: 84be28169764ee62

Many thanks

The logs seem fine.

Are you sure your on the same network?
Asking this because service discovery (which is what is being used to ‘find’ the RoPieee unit) requires to be on the same network… Just to make sure you’re not connecting to the ‘guest’ network by accident :wink:

Regards Harry

Yes I am on the main network login, the router just has one.

I am just about to put this router (came with my fibre broadband recently installed) into bridge mode so I can use my previous wifi hub, as I’ve found the wireless on the Nokia they supplied is not very robust and I’m getting drop outs with Roon.

So when I’ve done that I’ll check everything again and let you know… :blush:

Thanks

Just another data point — it has been working on my 2020 Intel MacBook Pro for the last couple of years. I currently run MacOS Monterey and the latest RoPieeeXL, but it was also working when I was running Big Sur and the old version of RoPieeeXL.


1 Like

'tis indeed weird?

@spockfish

Hi Harry,

Network finally all stable again, Pi4 (with Allo DigiOne HAT) updated to latest Ropieee download all ok, all iOS devices can stream to Airplay and show icon/name in airplay list ok but my MacBook Air stubbornly refuses to show Ropieee in the list of airplay devices still… weird one?

Cheers
Tim