Ropieee XL Install with Raspberry Pi4

But did you boot up before installing your screen? If you did, you have to reflash.


Thank you very much look forward to hearing from Harry


Sorry Jim I don’t understand.
The screen was connected to the RPi4 with power only using two small fly leads these came with the screen.
The SD card was flashed with RoPieee XL and power was applied to the RPi4

Can you get to the web GUI in a browser? If so go to the advanced tab and send a feedback and post the number shown here for Harry to decode the packet sent

Use http://ropieee.local to access

But… RoPieee does not use the screen (except the official touchscreen), so there is not something as ‘frozen’. What does the green led do? Have you tried to connect with RoPieee’s web interface?

As Harry says, you now need to go to your web browser, and go to the web administration pages of your RoPieee installation. Until you set it up in the web administration pages, your RPi screen will be blank.

Hello @Matthew_Hoult. I compiled a guide which might be helpful to you, if only to identify how your experience so far deviates from the normal install process?

The LED flashing rate (fast, or slow at 1/2 Hertz) indicates the install completion status, and the web gui is the next step of the process.

1 Like

I was having a similar problem with a RPi4, and not just with Ropieee. Whatever I used, installation (or booting off something setup on a RPi 3) would hang. During startup, I could ping the device, then it would stop responding to pings, and the ethernet port lights would lock up or go off altogether.

Doing a bit of digging, it appears that a few people have similar problems with the ethernet ports.

So, I setup another distribution that will create a wireless hotspot, then logged in and ran:
“sudo mii-tool -R”

From that point on, the ethernet port has worked fine and I was able to setup Ropieee (the first boot did take quite some time).

The green LED starts off flashing at a high rate but now its off no blinking just the red LED on

I am using the official RPI touch screen.

The RPi4 has been returned and a new one ordered.

My Brother brought a RPi4 and we loaded up RoPieee is about 10 mins no longer it was all very easy, lets hope my new Pi works correctly this time

It should. I’ve assembled 3 of these using RPi4 with no issues.

Jim that’s good to hear

1 Like

The RoPieeeXL 2.450 is running as a charm. I tried version update from web interface, but this doesn’t work.

So I flashed the 2.566 to another SD card. Very long bootup time. Then I configured RoPieeeXL with web interface exactly as in version 2.450 - no connection from Roon and no connection from HQplayer possible!

The 2.566 is simply NOT running correct for me. :frowning:

Can you send feedback? You can find that on the ‘advanced’ tab in the web interface.

Ah sorry, my fault. I forgot to enable “Audio USB” in the Roon tab.