RoPieee XL/Squeezelite Volume control

@spockfish Just realized that volume control cannot be set to None in Squeezelite configuration tab. Is there any reason for that?
Thank you

Squeezelite does not have a “no volume control option” at all.

I could make it virtual by setting the volume to 100%, but right now it just reflects what is possible on the software side.

Thanks, the question arises from the fact that I am “struggling” with Daphile to play DSD on Squeezelite / RoPieee XL
RoPieee XL is installed on a raspberry pi4 with HiFiBerry Digi + Pro connected in coax to an M2TECH Young DSD dac.
If I use Upnp / DLNA I can play DSD64 in DoP but using Squeezelite I get a lot of noise and very low music instead.
Do you have any suggestions?

Hi @Stefano_Antonelli,

I’ve never experimented with DSD/DoP in combination with Squeezelite.
However, I’ve did some research and although the documentation is not very clear about it, I think it should indeed be possible to do DoP.

I’m going to experiment with this later this week, I’ll keep you posted.

Thanks

Same issue here with Daphile and RopieeXL Squeezelite playing DSD.
In my case, Daphile converts DSD to MP3 on Topping D10s.

Hi @Stefano_Antonelli,

Did some testing with DSD and Squeezelite.
Worked out of the box, after configuring the DSD plugin in your slimserver.

I assumed you did that? On my end I did not had to change anything. Just play some DSD content and it works.

Thanks for testing Harry.
My chain is rpi4/HiFiBerry Digi+ Pro/coax/M2Tech Young DSD (DoP only dac)
In Daphile I configured in Advanced Media Server Settings/Player/Daphile “Enable DSD over PCM” (but the same result is unchecking it)
and the file is played with a lot of noise and displayed in the dac as 192 (should be DSD1, that is for DSD64)
The same chain works if I use Upnp/DLNA enabling DoP in the Upnp/DLNA configuration tab

I’m not familiar with Daphile so I can’t help with that.
As you can do DSD from LMS I suspect this is on the Daphile side of things.

Thanks

thank you Harry.
In the meantime I tried with PiCorePlayer and GentooPlayer with success:
as far as I can understand the missing thing in RoPieee XL/Squeezelite configuration is the possibility to enable DoP mode, just like it can be done in Upnd/Dlna configuration.

Hmmm… I’ll need a look.
Could mean that with my test from yesterday I was indeed sending native DSD and no DoP.

If I figure something out to test are you willing to do that?

The scenario should be: Daphile playing to a raspberry/RoPieee XL with a hat like HiFiBerry Digi+ Pro. This hat can play DSD in DoP up to DSD64.
In this scenario Daphile recnognize the raspberry as native DSD capable therefore doesn’t provide to convert DSD in DoP and the DSDPlayer plugin warns that the player (RoPieee XL) is native DSD capable and that DoP mode should be set in the player, this is what I have done with PiCorePlayer and GentooPlayer as they are able to set the player as DoP.
The documentation I could find explains that DoP should be the default, but in the upper scenario I found it must be set esplicitly.
In any other scenario (rpi to usb dac native DSD or to usb dac DoP only) it works correctly.
I hope I could explain myself …
… and please consider myself available as a tester …
In the attached screenshot you can find how I set the parameter in PiCorePlayer

Yeah found it. And tested it and it works.

My test DAC fooled me into believing that it did DoP, where indeed it is being converted to PCM. With the ‘-D’ option this is solved.

I’ll build this option into the beta channel for you to test. I’ll let you know when it lands in beta.

Thanks a lot Harry!

Psssstttt…

This just landed in the beta channel.

Just updated and it works!!!
What a wonderful support!!!
Thanks a lot Harry

1 Like

Thanks for testing.