RopieeeXL does not always update

Hi, not a huge deal since it’s always possible to reflash, but for some reason, my RopieeeXL does not always update on reboot even though it’s set to do so. For example, right now, it’s on 2.534 and I have rebooted several time and it won’t upgrade to 2.535. Just sent feedback 21d092653c0ebf41.


That’s because you’re on the beta channel.

Says stable on the Advanced tab…

I also tried changing to Manual update and it does not show there is an update available…

Sorry. i was to brief.

You were on the beta channel when we are testing with various stuff.

The stable channel reflects those packages, with only a difference in the version number. RoPieee does not consider that an update and ignores it.

I guarantee you that, if you stay on the stable channel, you will receive an update on the next release :slight_smile:


1 Like

Hi, similar problem here. I’m running RopieeXL. I haven’t checked the web interface in awhile and noticed I have a “Update available” message. But after updating and rebooting, I’m still at release 2.45. I’ve tried multiple times. Or is that the most recent release for XL?

I reflashed mine today to resolve this.


I hope this is the right place to post…

My RoPieeeXL has stopped auto-updating on boot. Sent feedback – f223264c477c9aaa. I’m on the stable channel with 4.017 being the last applied update.

BTW – a supporter and a lover of Ropieee XL.

If I must reflash, is there a way to keep all my settings?


Disregard. It seems that 4.017 is the last stable with all other being beta. I guess I failed to see that when reading change-logs and the new NG naming convention. Switched to BETA and received 4.019. I’ll be watching the NG development closely.


The new version is already released last week.
So if you want to have future updates you need to reflash.

Read here:


Re-flashed and enjoying the NG version. Easy-Peasy Lemon Squeezy!!

Thank you!!

1 Like