RopieeeXL Librespot not working?

Hey all

I have a RPi4 and display now set up as a Roon display for my sotm sms-200 endpoint. That works fine.

I am trying to set up Librespot on the RPi4 for Spotify connect. I have a USB cable connected from the RPi4 to the dac (rockna wavelight) and have usb input selected on the dac.

I’ve entered my userID and password on the Pi page. Have committed the changes and rebooted. However I don’t see the RPi4 on my Spotify Connect.

Any ideas?

I can use librespot on my sms 200 ultra, but I was thinking if I could set it up on my RPi4 instead and just switch input selections on the dac as an easier method, rather than having to go into the sotm eunhasu webpage each time to swap the active protocol from Roon to Librespot and vice versa.

Have you tried stopping and restarting the Spotify App on your phone?

Yep. Have restarted the sotm, switch, dac, phone.
Wondering if there is any step I’m missing?

I set the ropieeexl to librespot and USB. Save changes. Reboot. But after booting, I check librespot again and the audio output box goes back to default/no/none.

Are you sure audio is working properly? Have you tried Roon this way?
If the USB DAC is not seen by the RoPieee unit then it will also not show up in RoPieee.

Yep, the dac works and I get audio when I connect my laptop directly to the dac via USB.

I have the same issue on my RPi3. It works fine sending Shairport from the same iPhone. I’m on the Beta channel.

Yeah… but that was not what I meant. Do you have audio via the RoPieee unit?

I think the Ropieee cannot detect the dac.
I’ve not been able to play any audio from the dac.
Have u had any reported issues with other users using Rockna dacs?
I will try source another dac and hook it up and see how it goes.

Can you send me feedback? You can find that option on the ‘advanced’ tab in the webinterface.

OK will do.

Here is the identifier.


Uhhhh… you disabled USB audio!

(it’s on the first tab).

Hence no audio device, and no visibility in Spotify (or any other streaming platform for that matter).

1 Like

I have tried to enable that.
And the I commit the change.
And then I reboot. And after the reboot, it goes back to disabled by itself.

can you enable it again, commit it, but do not reboot and send me feedback.

1 Like

Ah I tried it one more time after rebooting the dac.
It works now, thanks very much!

I had no idea the first tab was relevant to Librespot /Spotify, as the description on the first tab reads “This section contains the basic settings for RoPieee that are required for it to function as a Roon endpoint.” so I assumed it was only relevant for Roon purposes.

Cheers for the help!

Yeah… you have a valid point. I’ll change the text a little bit.

1 Like

I am having trouble getting Librespot to show up in the Spotify app and this post looked really promising. I also had USB Audio turned off and I have since enabled it but the DAC (HiFiBerry XLR) does not show up.

Here is my identifier: ddb3a964870353dd

Thank you everyone.

Your dac is a HAT therefore you need first to enable it in the Roon page
and then set Audio output in Librespot to HAT

Thanks Stefano, done all that but with no success.

Is this the correct HAT for HiFIBerry’s XLR? There are no clear options to choose from?