RoPieeeXL: no audio from Airplay or Spotify

Hi, fresh new user here. Very happy with Roon and RoPieee.

Roon audio is perfect using the remote on an iPad.

Only issue is that Airplay is not working. Apple Music finds RoPiee, seems to be playing music (time increasing, bar is moving), but no sound.

Same with Spotify.

Any thoughts on this?

Log file is a82bde3ef2a20c15.


Do you have to set the output for each?

Both are configured to output to USB.

Isn’t Roon RAAT blocking the device exclusively?
This happens to me when i switch from HQPlayer NAA to native Roon Endpoint.
I have to disable the Roon Endpoint for HQPlayer to see the NAA device or switch HQPlayer local mode to be able to enable the Roon Endpoint.
What happens if you reboot the Pi?

You use both at the same time: that won’t work.
Reboot your unit, only use Airplay, and if that still don’t work send me feedback.


1 Like

Checking this, thank you.

1 Like

Nothing. I have sent in a new log: 492ac55b437824fd

Only Spotify enabled. Roon server not running, RoPieee rebooted.

Spotify finds the RoPieee, but as soon as it starts playing it reverts to the iPhone speaker. This happens again and again.

Thank you!