RP2 Hifiberry Digi Pro Roon 1.3

I would like to share an experience arround the upgrade to roon 1.3. I have a RP2 with Hifiberry digi pro card.

The endpoint dissapeared one day arround the upgrade. I flashed the sd again but endpoint still did not show. I installed dietpi with roon, still no show. I then checked the intalled soundcard by writing aplay -l in the terminal on dietpi. The endponit emediately showed up in roon?

It might be fingertrouble and nothing to do with roon 1.3 or it might help you if the endpoint does not show up.

Without being the topic I love Diet Pi instead of the Hifiberry image.

I use mine with the Rpi 2 Arch Linux ARM release (not 3 release, even though I have an Rpi3. the 3 release is 64 bit apparently and not well supported).

I actually have two of them - one with Digi+ and another one with the DAC. They are actually both from a company called “Kuman” which uses the same chip (PCM5102 BURR BROWN - 24bit/192 kH) for their offering, but since they use the same dtoverlay parameters, chips, and have the same output, I am assuming there isn’t much of a meaningful difference. If there was a difference, I’d expect hifiberry to be better supported anyway.

Both work exactly as expected after adding the following to /boot/config.txt

Since for the digi+ I have it doing pass-through, it just works and is based on my receiver’s volume. For the DAC you can check it out in alsamixer if you install alsa-utils (and roon remote can control the volume as normal too).

I think you can safely assume it has nothing to do with your sound card - it would detect the device on the network and notify you that you have no sound output options or only the usual built-in ones (headphone jack/hdmi out). Those outputs don’t get disabled for me with the extra sound card. I suggest you just reinstall roon-bridge.

(I have no experience with the HifiBerry image - but if you are comfortable with linux I can recommend the build of Arch Linux ARM for Raspberry Pi 2. Roon Bridge works well for me with that image.)