RPi 4 is ARMv8 but armv8 bridge installer errors

Hope someone can set this RPi neophyte straight…

Just tried to run the roonbridge-installer-linuxarmv8.sh file downloaded from the standard roon download url on a RPi 4 running raspian lite.

The script exits with the error “This package is intended for armv8 platforms. It is not compatible with your machine. Exiting.”

But the RPi 4 is the ARMv8 platform.

Can someone shed some light on this and get me going if that is possible.

Thank you.

Okay, I see. Command uname -m returns armv7l (that is a lowercase L, not a number one) , not armv8.

Is this expected, and right? Or is this a failing of raspian lite build for raspberry pi 4?

So, do ya think if I update the .sh file to account for that armv7l version identifier, the bridge software will install and run without a problem?

Just download the armv7hf installer – it works fine.

Current distro’s (Raspbian/Arch/etc.) still target the Pi4 as ARMv7.

Yes, thanx. Yes indeed. Worked as suggested.

Tho I’m scratching my head as this script has the same ARCH validation which should have exited when it encountered MACHINE_ARCH equal to armv7l. So I’m not entirely sure why. But that’s my problem.