SACD ripping problem

I had to temporarily repurpose the USB drive that had the Pioneer SACD ripping scripts on it.

I now put them back on, from the original source. But now it doesn’t work. The draw opens, but the PC end crashes.

I’m flying totally blind here. No idea how to trouble-shoot.

SACD player is pingable from PC. IP address is correct. Have rebooted PC and SACD player multiple times.


I vaguely remmeber this happening to me as well a while ago. Do you see your player among the network devices in the explorer window? I think in one of the accompanied guides for the Pioneer players that was emphasises when using windows (sorry for the limited help, I’m writing from the phone as my desktop computer is in boxes as I’m moving to another apartment in a few days)

I have some ideas, as follows:

  • If you use windows, safely eject the USB drive, not just pull it out

  • Check the type of the files (.exe vs .whatever)

  • Check if you did update the firmware of the SACD player

If you can not save your problem in the coming days, report back and I will set up my Pioneer 160 to check and
send you my setup details.

Did you reformat the USB drive, and if so to what format?

Drawer shouldn’t open if wrong format, but just in case.

At first setup of my BDP-170 I also had crashes of iso2dsd. It turned out that this was caused by the auto-play function that was enabled by default. After turning auto-play off all was working fine.

If it worked before it might not make too much sense that a setting returns to its default, but you never know…

The USB drive is formatted as FAT. I have also tried ExFAT. (And I eject USB drives tidily.)

I have checked the folder and file names and repeatedly dragged them in from multiple versions of the source.

Auto play is off.

It would be very mysterious if the firmware got silently updated as Iturned that off too.

Either there’s something simple we’re missing or the machine has changed its settings!

I found the problem thanks to the thread over at CA. When formatting as FAT I had left GUID Partition Map as the scheme when it should have been Master Boot Record.

Now that I’ve fixed that, the Pioneer reliably ejects its tray and talks to the PC. Ripping is once more underway.

Thanks all!

1 Like