Sage Green Phantom II "Uncertified"


I picked up a couple of Phantom II 98dB speakers in the Sage Green fully expecting them to be compatible with Roon but they are listed as “Uncertified” in the Audio tab. These should be the same as the already supported Phantom II 98 but with a different shell (See: Phantom II 98 dB Green).

What is the timeline before these are unlocked as Roon Ready?

I am using Core 1.8 build 814 if it is of help.

Did you update the firmware on the Phantoms?

Yes. They are both on (and came with) version 2.13.2 which appears to be the latest:

Weird. Maybe try rebooting your core to see if that makes a difference. The Phantom IIs are meant to be Roon Ready and I can’t imagine that there is anything different about the sage ones.

I am going to tag @support to see if they have any ideas.

Thanks for tagging support.

I rebooted both Phantom IIs as well as the Core based after a quick search for Uncertified on the forums.

Log out from Roon. Reboot Roon Core. Login to Roon again.

Logged out (via Settings → General), rebooted the machine, and logged back into Roon when prompted. I still see Uncertified.

Please post a screenshot of the setting screen showing the model number and Uncertified.

Hi @ipta , I am sure @wklie knows how this is supposed to work as he maintains lots of RAAT implementations at Lumin. AFAIK the device informs Roon of its ID during RAAT handshake. If there is no match it’s Uncertified. (@wklie is the DEVICE INFO text used as ID?)

Either Devialet has “forgotten” to inform Roon about the new device or Roon has not (yet) updated the RAAT descriptor data base with an entry for the Sage Green. Or maybe it has been done but not replicated to all cloud nodes.

I see a problem here and I don’t think it’s related to user-side settings. You will have to wait for support @john to follow up.

Hi @ogs,

I’ve just pushed an update to the device identification script that should resolve this issue. A quick restart of the Roon Core process should result in the device appearing as certified. Let us know if this doesn’t resolve the issue.



Hi @john it is actually @ipta who has reported the problem, but thanks for the swift response! Hope this resolves it!

thanks @john. that resolved my issue. I can enable roon on the green phantoms