Schedule Alarm Clock to start Internet Radio


(Bart Maguire) #1

Can I schedule an alarm to start an internet radio stream?
At the moment I have my Squeezebox wake me up with the news on the radio in the morning. Can I do the same with Roon so that I can turn off my Logitech Media Server and use my Squeezeboxes as Roon endpoints?


#2

(Bart Maguire) #3

Thanks,
I have seen this and I have it installed.
It is missing one vital piece of functionality - it only plays what is in the queue, it does not play an Internet Radio station if that was not the last thing that was playing before stopping.
I need something that will play the radio in the morning so I can wake up to the news but I never listen to that stream except in the morning.
Jan_Koudijs was going to implement internet radio preselection - did this happen?


#4

Are you sure you have it installed? Maybe you should try it out then. I have no problem to set the source for an Alarm. Just make sure you use the latest version.
grafik

I installed it in the recommended way by using the Roon Extension Manager, which has manual and automatic update mechanism for managed extensions.


(Bart Maguire) #5

Oh, I had an old version installed.
Now I have the Roon Extension Manager and the latest version and it is working!
Thanks for the help.


(Doug Ogilvie) #6

Thanks for the info. I will keep this in mind.

Although, are you sure you want to start the day out w news as the first thing? Maybe ease into the day w a little Bill Frisell for the first 20 minutes?


(Bart Maguire) #7

Well, it hasn’t worked.
I set up an alarm but the next morning it doesn’t work.
Looking at the Extensions I see that the Extension Manager and the Alarm Clock are not there any more. They are running as containers on my QNAP, when I restart them they re-appear but then get lost some hours later.
I tried to follow the directions to add a restart command but obviously this has not worked.
One of the directions was to use the Starup.sh script from @Jan_Koudijs but this does not run on my QNAP. It gives an error “Please install systemctl”.
Can someone give me help to uninstall and clean up all the extensions and then to re-install the Extension Manager and the Alarm Clock and set them to restart if they stop?


#8

Just stop and delete the container to uninstall. Use the instructions from following thread to install with auto restart on QNAP.


(Jan Koudijs) #9

Hi @Bart_Maguire,

Did you succeed in getting it up and running by following the instructions given by @BlackJack?


(Bart Maguire) #10

Hi,
I stopped and deleted the containers and then I re-installed the Extension Manager using the command line given in that thread.
It seems to be working so far.
I will update you later in the week after I have had a few days to make sure.


(Bart Maguire) #11

Seems to be working, has woken me up every morning on time so far.
Would be nice if the alarm function was built-in and had an easy to use interface from the main screen instead of being buried in the Settings menu. Thanks to the extension developers though, for filling in this gap.