Sending audio from RoonServer Core to Remote; What's wrong here?

I’m probably missing something simple:

I have RoonServer running on a headless Mac Mini, controlling from either an iMac27 remote or a MacBook Pro remote.

Is it possible to send the output from the Mini to one of these remote computers, such that I can listen on headphones or system output on, say, the iMac27?

My sense from reading is “yes.” I set Roon to see the iMac27 in two different zones, one for ‘headphones’ and one for ‘system output’, and tried both by changing the output device on Core from my usual DAC setting to one of the two new zones.

Nothing.

In checking the Zones display, even though I’ve selected “iMac27 Headphones”, the waveform display is active under the previously selected DAC output.

Thanks for any input that will help with the output!
Rob

Hey @Rob_Hanson,

The remotes can run private zones, which means they can be controlled by the remote, but not by other instances of Roon.

You should be able to enable a variety of configurations on the iMac or MBP by visiting the Audio tab of their respective Settings screens.

Hi, Mike –

Thanks for the reply. Sadly, I think I’m still a bit confused by zones and Roon’s capabilities, so could you simplify it a bit for me?

Okay, so RoonServer is running on the headless Mini, feeding my stereo DAC stack. I’m controlling what happens on that RoonServer system by running Roon on one/both external Macs. (Are these called “remotes”?)

Neither external, “remote” Mac has a music library local to it. Everything is on the Mini.

So, am I able to address RoonServer on the Mini from one of my external “remote” Macs and play that Mini’s library outputting the sound to the external, “remote” Mac?

If so, then I seem to have an issue with the iMac27. I haven’t had the chance to try it on the MacBook Pro. But, I tried declaring the iMac27 to be a ‘zone’, with one zone for system output and one zone for headphones. If I play a tune on RoonServer, it plays to the (local) stereo stack with no issues. But, if I try to change RoonServer’s output to zone “iMac headphones” or zone “iMac system output”, I get no sound.

Simplified, does RoonServer allow me to “pipe” music over to another Mac’s output?

Thanks,
Rob

You need to select the headphone zone that is on your remote…not the core. The remote headphone is a private zone that the roonserver cannot control. It has to be managed at the local end.

Not sure that is any clearer but just select it on your remote installed Mac.

Okay, @ncpl

That’s good to know. It would seem, then, that I either have a problem, or that I don’t know what I’m doing. My guess is the latter.

Sitting at my iMac, I use Roon to connect to RoonServer on the Mac Mini. Right now, the Mac Mini is driving the stereo stack in the other room nicely. No complaints.

So, at my iMac, I can set up a ‘local’ zone private to my iMac in the Settings > Audio dialogue. My choices are either System Output or Headphones. Fine. I’ve enabled both of those zones.

Continuing on, at the iMac (and interfacing to RoonServer), I set that currently playing output from my DAC stack to iMac Headphones. I hear nothing. Same for local system output.

As I’ve said, I either don’t know what I’m doing, or there is a problem. I think I’m just missing one step in the process.

In effect, what I’m trying to say is, “Hey, RoonServer over there on my Mac Mini headless stack; please send your output over here to my iMac where I’m now sitting.”

That all sounds correct, but the Private Zones on your iMac each have their own Queue and need to be told what to play. Just select and play some music in the usual way on the iMac with a Private Zone selected as output and you should get Roon sending one audio stream to your DAC and another to your iMac.

If you’re still not getting sound after playing from a Private Zone Queue I’d suggest checking audio on the iMac generally. Do you get sound there outside Roon ?

Roon can send the same output to multiple zones (Grouped Zones) but they have to be the same type (AirPlay, Meridian, RAAT).

You can also transfer output from one Zone to another using the “Transfer to” button in the Queue.

1 Like

Thanks @andybob

I’ll try those things a.s.a.p.

And yes, I do get sound output on my local iMac. I just don’t think I’m tweaking the right option.

Well, in the limited time I have, I tried your suggestion @andybob. It worked, albeit a bit too well.

See, I have “Force Max Volume” on RoonServer, so when I said Transfer To… iMac27… as I was at the iMac… I kinda got blown away.

The DAC stack went silent, and my hair slicked back. At least I could call that “progress.”

2 Likes