Separate MacBookPro as Output-device


I have one Mac with Roon Server and Roon installed.
I have another Mac, which has a DAC connected via USB.
Now I want this second Mac install as an Output Device.
But Mac 1 doesn’t see Mac 2 in the network.
Starting Roon on Mac 2 and connecting to the Core on Mac 1 shows only the devices of Mac 1, but the proper ones!?

How can I either make Mac 2 appear unter Audio, networked devices
or make the proper devices appear when controlling from Mac 2?

Thanks very much!

Verify that firewalls or antivirus are not interfering with the server discovering the audio devices on the client

You need to run roon bridge on the non core Mac then you should be able to add the dac to that bridge location in the remote core settings

1 Like

Actual configuration:

RoonBridge running
System Preferences: Security&Privacy: RoonBridgeHelper: Allow incomming connections
System Preferences: Sharing: Screensharing and Filesharing are enabled

Roon running
System Preferences: Security&Privacy: Roon: Allow incomming connections
Settings - Audio: still only CoreMac-Outputs visible!?
Starting Roon on my iPhone: visible under Networked!

Or have I missunderstood your hint “you should be able to add the dac to that bridge location in the remote core settings”?
Where do I have to add the DAC, where are the remote core settings (which Mac, App, Menu)?

Thanks so very much for helping me trough this!

My Windows 10 Pc is running bridge but the principle is the same for any networked roon capable Pc or Mac or raspberry pi even.

It’s sad, that it works perfectly with a rapsberry pi, but not with my MacBookPro :slight_smile:
Next week I’ll do a test with my mac mini at a different location - will let you know about the outcome …

You won’t see the dac unless it’s powered on and connected to the network device running bridge.

Likewise they must be on the same network segment.

Do you see the dac in the system details under about this Mac on the usb list?

The DAC is powered on and works perfectly when playing form that Mac directly via iTunes.
Also visible within the usb-list.
Same network on of course; otherwise I couldn’t share the screen.
Bridge running.
So everything as it should be.
As mentioned, I’ll do a test within a different enviroment, where all this worked once.
If that does work, I’ll check for the differencies!
Kind Regards

As I expected, here within a different enviroment it works all perfectly.
It’s not really the enviroment, but the MacMini I have connected via Bridge is properly installed.
The Mac I used in our history above is obviously wrong installed; too complicate to explain here in a few words - I’ll fix this and then it will work there too.
Thanks for your kind support!
Kind Regards

After a total re-install at the mac-shop (so surely all correctly done!) and installing nothing but roonbridge: still not visible by Roon on the Main-Mac.
Testet also with another MacBookPro: perfectly visible too!
VERY strange !!??
Kind Regards

Have you enabled the Mac as an output in Roon?

You don’t, by any chance, have it set up as a private zone?

Thanks Jonas and David, BUT, you havn’t read the history of the case …
The problem is, that the freshly installed and technically checked Mac is NOT visible in the Audio settings of the Main Mac.
The other Macs ARE visible there and can therefore be enabled as Output.
So, why can’t I see that Mac, allthough it is in the same network of course, is on factory default plus roonbridge?!

Kind Regards

Hi Gert, I was the first reply to you, but, I don’t think you ever got back to me on my suggestion. Try turning OFF all firewalls and anti-virus on the remote Mac. I believe that the are enabled by default even/especially in a fresh install.

FYI, Audio Outputs are displayed when the Server sends an inquiry to the client and gets a response. If this query is blocked no audio devices will show in the client. And the most usual cause for the blockage is a Firewall or Anti-Virus. And the quickest way to test is to turn them off and see if the Audiio Devices appear. If so, then you can re-enable them and add the appropriate exceptions.

Thanks Daniel
I tried that within the old installation and after the reset at the mac shop there was no firewall and no antivirus and still it didn’t work. After turning on the firewall, roon asks for some permissions which I grant; same result.
We also checked within the activity monitor: two roon processes are running there; looks identical on the macs, that do show up within the audio-setting.
strange, isn’t it !?
Kind Regards
P.S. by the way: I did reply to your first post, but via email instead of here …