Shairport streaming broken in 2.566

Dear Harry,

since the latest Update, I can’t use Shairport streaming on RoPieee anymore. The streaming always stops after 3-4 seconds. Streaming to other Airport/Shairport devices works. RAAT streaming from Roon also works.

Source iTunes or Roon 1.7 (571).



I just tried airplay to my RoPieeeXL setup and it’s playing fine. I’m on the latest beta though. Same iTunes version as you.

hope that helps,

Hi Matthias,

I can’t read your feedback archive, so I’m seriously wondering if your SD card is fried…
Maybe you should try a reflash.


Hi Harry,

I did a reflash, but unfortunately Airplay streaming still stops after a seconds.
Feedback: 9f4229efaad1f703


Hi Matthias,

At least you’re playing excellent music (saw you were playing Tool :wink: )

The weird thing is that the MDNS daemon crashes… resulting in the Airplay component quitting as well.
Never seen this before…

So, can you switch to the beta channel? You can do that in the ‘advanced’ tab. It makes debugging this (and experimenting) a bit easier.

Switch to beta, and let’s see how that goes.


Hi Harry,

I’m now at 2.570beta, but still the same behavior…


Yes, the last Tool Album is great, but it won’t play :frowning:

Have you also updated on the beta channel?

Yes, it updated immediately to 2.570 beta after I activated the beta channel.

Ok cool. But I can’t read your feedback archive for some reason.
Can you retry?

Just to say (might be related) I’m having the same issue and when I log into Ropieee there is a “hardware mixer not supported” message alongside USB output for all services including Shareport-Sync. Just sent feedback 21fc291813899060. Have rebooted but to no avail, iOS devices or Mac thank they are connected but no sound emerges :blush:


No, the message is just wat it is: an informational message that you can’t select ‘hardware mixer’ for volume control.

hmmmm… same result :frowning:

As soon as it actually starts playing the M-DNS daemon crashes, resulting in the playing to stop.
I need to figure out why this is happening on your system and not on mine.

1 Like

Hmmm… @Tim_Woodward your issue is however the same: M-DNS daemon crapping out :frowning:

Ok, sorry to unearth that for you as well! :blush: I don’t use the XL Airplay feature too much as I find it a bit hit and miss anyway, it usually fails to connect first time, particularly on IOS devices - not so bad on the Mac though but if it doesn’t connect then a reboot is usually required. I’m wireless connected by the way.

@Supersonic I"ve pushed an update to the beta channel.

Can you try it out? Thanks

This seems to work! At least it’s now playing for a while…


Ok thanks. The logs seem ok indeed.

Hi Harry - I think I have something similar - have just updated to beta release and will see if it reoccurs.

Basically, streaming via airplay from iPhone using Tidal, I get a pause in play, and then rapid stuttering of the music. If I reconnect it fixes itself but randomly happens again. Wonder if it is a different cause. Will try and send feedback if it happens again