Slow Search Issues

Rebooted still some slowish search’s but better than it was. Radio seems to have returned but It just failed to find anything similar in my library for a track off Qobuz, which is odd as I have 3 albums by the band and it not as if they are unknown. It was Vampire Weekends new track, which Roon identifies the genre. Timestamps all between 20.27 GMT and 20.35-36 for the last issue.

Remember my accounts not the same as my forum one so do you need me to message it to you?

@CrystalGipsy - I still have the email address. Will check diagnostics and get back to you but it is possible that the Radio algorithm does not have enough useful data to start radio off of the track, you did mention that it was just released so I imagine this is the case.

– Noris

Hey @CrystalGipsy,

I’m seeing some strange behavior in the logs, so I have created a ticket for you and am passing it to QA for review.

I know you mentioned you switched over to Google DNS on the router at one point, is that DNS setting still valid or has that changed? The reason I ask is because I’m still seeing traces of Name Resolution Failures in your logs.

Please let me know when possible.

Thanks,
Noris

I will check but I don’t remember changing it from Google. 8.8.8.8

Hmm I wonder if this is my switch. I have a cisco catalyst 2960 switch but it’s in unmanaged mode so it acts just like ordinary switch, however it does have protection against spanning tree which means ports do not come fully active for about 30secs as it’s doing checks. I do notice that when I reboot the core that the tidal and qobuz report they could not login on the restart. I have to restart just Roon server for it to login ok then it’s fine from then. If this what your seeing in the logs?

I’m still getting very slow searches and albums take a long time to show up. This is very variable to. Something’s still not right it’s been like this since 1.6 update.

Hey @CrystalGipsy,

Nope, it’s showing up as NameResolutionFailure:

01/29 20:25:06 Warn: Error in web request https://metadataserver.roonlabs.net/md/4/updategenres?uid=11457dfd-50c4-4002-8862-97908c412a59&lid=&token=511132e3-67fe-4318-8f4e-9ca87947f76a&content_hash=30192aee32efe9356b00bf2fd4340f77: NetworkError (Error: NameResolutionFailure)
01/29 20:25:07 Warn: Error in web request https://api.tidalhifi.com/v1/sessions/654fdbfc-9181-48c6-b79f-31b972cd415f?token=Imi5DLPIAVRmszdL&: NetworkError (Error: NameResolutionFailure)

Hmm, would you be able to bypass the switch to see what the experience is like without it? I do wonder if it could be the spanning tree coming into play here, but that’s unlikley to be the cause of DNS issues.

Also, I looked up the Vamipre Weekend track you tried to start Roon Radio off of, and my previous assumption is correct, since it just came out there isn’t really much information for Roon Radio to go off off. I have asked the team to see if we can do better here in a future Roon update and will let you know what they say, but do let me know if there are any changes to the main issue if you bypass the switch.

Thanks,
Noris

As this did not show up before i will reboot the router, switches etc to see if this rectifies.

@noris i have rebooted my entire network can you check the system to see if the DNS NameResolutionFailure is still occuring. It does seem snappier as a result of this. And for good measure I have changed all the cables for this part of the chain.

@CrystalGipsy - It looks like the last Name Resolution Failure was ~30 minutes ago:

Line 464: 01/31 00:50:11 Warn: [updatemetadata] neterror in updatemetadata: Result[Status=NetworkError, ErrorText=Error: NameResolutionFailure]

I think we should leave this overnight and then please ping me again tomorrow to check again for any DNS errors.

Thanks,
Noris

My network rsystem may have been down then as it was about the time I powered it all off but i left the core running before I turned it off. Will get back to you tomorrow time for sleep.

1 Like

I checked the logs this morning no further DNS resolution issues. I think that is when I boot up the machine and the switch is then taking a while to initiate the connection and port.

Will check in again later.

Hi Noris. The dns resolution errors do only occur on booting the rock machine which as mentioned is a result of the switch runnig STP as part of any device being connected and this denies any connection on the port for 30 secs whilst it checks all is ok.

This seems to make Roon server go in a panic and won’t connect to streaming services even after it’s all connected and has network/internet. It’s like it doesn’t bother retrying or has completely timed out, even if I press retry at the failed login prompt in Roon remotes UI. Only manually restarting just Roon server application will make it connect. This is a bit annoying any reason why Roon gives up like this. Is it because it’s not set the dns servers? Perhaps setting it to fixed up might help with it?

This aside still getting slow searches but Radio has been fine. I think the dns errors are a red herring for this issue though as they only happen as I said on boot due to the switch.

Hello @CrystalGipsy,

We are investigating some DNS reports on ROCK and I have seen a similar failure state. Can I please ask you to follow these instructions so I can add your report to the investigation?

  • Restart RoonServer from the WebUI (do not reboot the entire ROCK but just RoonServer)
  • Create an archive of the current Logs (https://kb.roonlabs.com/Logs) and name it “Fresh_state.zip”
  • Reboot ROCK from the webUI (the entire machine, not just RoonServer)
  • Create another archive of the current Logs and name it “Rebooted_ROCK.zip”
  • Check to see if you are able to access the network/ play TIDAL content
  • If you are not able to, go back into the WebUI and reboot just RoonServer again
  • Make another archive of the logs and name them “Rebooted_RoonServer_only.zip”

At the end of this process you should have 3 .zip files - Fresh state, Rebooted ROCK and Rebooted RoonServer only. I kindly ask you to upload these .zip files to our servers for analysis (I will PM you upload instructions in a min) and I will add this info to the investigation.

Thanks,
Noris

Sorry missed this last night. I will do this asap and let you know.

1 Like

Hey @CrystalGipsy,

I wanted to touch base with some good news, which is that our technical team has been able to reproduce this behavior and we’ve opened up a bug report with our developers.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved. Thanks again for the report!

– Noris

Thanks for the update. Nice to know I don’t have to change any of my network gear.

Hi @CrystalGipsy,

Appreciate your patience while we made some improvements in this area. We have just released Roon OS build 172 which addresses this issue, thanks again for your help here!

– Noris

1 Like

Great stuff all works now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.