Smooth DSD256 & DSD512 play using Chord DAVE DAC with Roon Nucleus +

To play up to DSD512 with the Chord DAVE smoothly using Nucleus + as server, you will need to run Roon on a Windows 10 PC.
I tried running Windows 10 on a ridiculously stacked Apple Mac Pro with 28 cores and 768GB RAM via Parallels Desktop and that does not give perfect DSD512 play.

What finally worked for me was using a simple Dell XPS Windows 10 PC, with ethernet connection to Roon Nucleus + and USB connect to Chord DAVE. I used an Audioquest Diamond USB but any USB will do.

DSD512 tracks with the Chord DAVE are so pristine and three dimensional with wide wide soundstages. Hard to find, but I recommend them, especially from the Danish and Japanese studios.

DSD512 requires “native USB DSD”. Apple’s OSX kernel does not provide a driver for this. No matter how big or small the Mac is, it won’t support DSD512 until Apple sees fit to add support in their kernel.
Windows works, of course, since Chord provides their add-in driver.

Linux supports it so long as the USB Vendor+ProductID is included in the native USB driver config when the kernel is built. Several of the RPi Roon endpoint distributions (such as RoPieee) regularly add new Vendor+ProductIDs as they become known/tested. I wouldn’t be surprised if an RPi with one of these distros would run the Chord DACs at DSD512 as well, though I’ve never tested it. You could always ask over in the RoPieee section of these forums; the RoPieee author is a regular participant here.

1 Like

When DAC is switching from say DSD64 to DSD512, there is always a popping sound. I tried setting the Resync Delay to something other than 0ms but that did not silent the issue. On the Mac where DSD512 is not natively supported and PCM downsizing is used, there are no popping sounds when switching between sampling rates like from 64K to DSD512 (which Mac converts to DSD256)

Would love to know how to silent this popping sound on a Windows PC.

Pops at sample rate changes are usually a problem in the DAC itself…

Also, doing some Googling, it looks like Chord native DSD is not supported on Linux as they don’t match any of the main USB interface chips (e.g., XMOS). Bummer. DSD512 will require a Windows system with their custom ALSA driver for now.