Smooth scrolling with mouse that has stepped scrollwheel

I’m using the Roon client (version 1.8, build 795) on my Windows 10 PC and I’ve noticed that scrolling through the interface is not smooth. If I click and drag the interface (like scrolling on a touch screen) the interface moves smoothly.

I think it would be great to have this feature, and it seems like the foundations are already there as I can scroll smoothly with the trackpad on my laptop.

1 Like

Peter, I’ve moved this to support. Smooth scrolling should be what the product achieves; if it doesn’t that’s a bug or something to be investigated in your environment, not a feature request.

1 Like

Hi Joel, thank you - I didn’t realise this wasn’t the intended behaviour, hence why I raised it as a feature request.

A little more information:

I’ve tried three different mice:

  • My daily-driver Logitech MX master 3
  • A wireless Corsair gaming mouse
  • A generic USB mouse

All three exhibit the same behaviour: when scrolling with the scrollwheel, the interface moves in “steps”. When I click and drag, the interface moves smoothly, like it does when scrolling with the trackpad on my MacBook.

Interestingly enough, when I connect the three mice to my MacBook, the interface also moves in “steps” - so I don’t think this is a windows-specific issue.

I’ve uploaded a short video clip demonstrating this - in the first half of the video I’m using the scrollwheel, and in the second half I’m dragging the interface.

Demonstration Video

Same here, I also thought the stepped scrolling was the intended behaviour. Smooth scrolling would surely be nice. I do get smooth scrolling in other apps (internet browsers), so it’s not a system wide issue.

1 Like

On Windows in Mouse settings I can configure what the wheel does. Default is advance 3 rows. Set it to something like for example 5 and the steps are as expected bigger, set it to 1 and the steps are smaller. Set it to advance by a page, step size seems to the same as with 1 row but scroll direction changes.

@BlackJack There’s no way that changing system settings is an acceptable solution to this issue. Making this change does indeed make scrolling “smoother” at the expense of tripling the effort it takes to actually scroll around any application, not just Roon. Sorry to sound blunt, but there’s no way I’m doing this.

Out of the 7 apps I have pinned to my taskbar right now, 5 of them have smooth scrolling, so this is clearly not a niche feature - hence why I originally raised this as a feature request, not a bug.

I didn’t suggest that anybody changes mouse settings – I just documented here the current, and strange regarding “scroll by page”, behavior of Roon as something the Team can investigate on.

1 Like

On my Huawei Tablet its a real bad experince as well