Software won't update

After opening ROON, it tells me a software update is available. I click on the link, then click the update button. It tries then tells me “there was an error checking for an update” then I click the Retry now button but still it doesn’t update goes back to the Retry now button. The software is currently version 1.8 build 831.

I would download the latest version from roonlabs and install manually.

Try this and select the correct platform, it should give you the latest build.
Good luck
Roon Software Downloads - PC, Mac, Linux, Android & iOS | Get it Now (

I downloaded and installed the software. This brings me to Choose Your ROON Core screen which shows the ROON Optimized Core Kit showing Update required and a Connect button. Clicking on the connect button nothing happens.

Well we are going to need a bit more information I think to help further.
Roon Core is what build right now?
And maybe your full Roon system topology?
What is Core on
Remotes etc.

ROON Core version 1.8 (build 831) firmware version 1.0 (build 227). The Core is on my Windows 11 pc and the music files are on my Windows 10 Pro home server. No remotes presently. Both pc’s are connected directly to the same switch which is connected to my ASUS router.

Now I’m a little confused.
Your previous post said R.O.C.K.
But now you are saying core is on a win11pc?

ROCK would not run on a win11pc I think.

For Roon Core it should have Windows 64bit download.

Ok. I maybe confused. I have an Intel NUC which is running R.O.C.K. and the ROON software is on my Windows 11 Pro pc. I downloaded and installed the RoonInstaller64 to the pc. Sorry for the confusion.

Ok, makes sense now…kind of…lol.
So it’s the nuc that can’t/ won’t update it’s software?
Have you tried to reboot it at all?

I’m afraid ROCK software I am not very familiar with so hopefully someone else can chine in as to why it might not connect to update?

How do I reboot the NUC?

Press the power button, let it power down and the switch it back on again.

Also For ROCK installations, point a web browser to its IP address and view the admin web interface.

From there select re-install Roon OS, this will update both the Roon Operating System and the Roon Core.

More details can found on Roonlabs help site.

The reboot worked. Web interface shows the update was applied.

Thanks everyone.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.