Sonicorbiter no longer seen by Roon

I have been utilizing the Sonicorbiter as an endpoint in my Roon based system for the last several weeks.

However, recently I had to reboot my router for other reasons and now Roon does not recognize the Sonicorbiter although it does recognize other end points.

I have rebooted/reset all of the components in the chain to no avail. Any help would be appreciated.

I am having this same problem with my microRendu. I recently installed Cat6a ethernet cable in a few rooms to enable high quality streaming via Sonictransporter --> microRendu --> Peachtree Nova150 DAC. Software wise, I am using Tidal and Roon. Upon initial setup yesterday, all was fine. I listed for half an hour, went out to run around town, and came back a few hours later. When I tried to listen to music again, Roon would no longer recognize the microRendu. I tried rebooting both the Sonictransporter and the microRendu via, but so far it has not worked. Perhaps I will climb up behind my cabinets where the microRendu is kept, and disconnect power and reconnect.