SONOS S1...S2....Sonos Move and Sonos Roam

Got my 2 Roam devices two days ago. Love them especially for the porch in the garden. I have a lot of older Sonos S1 equipment as a backup system and I would like to group the two roams with my connect S1 and sometimes with my old play5 (S1). The roams show up as two audiozones (airplay and sonos stream) and I can group the roams with the sonos streams with my Sonos connect. However, when I press the play button Roon tells me it has lost the device, then it sometimes does nothing at all and sometimes it will ungroup and start playing through just only one of the roams. I must me doing something wrong since others seems to get it to work.

I haven’t really tried grouping the Roams through a controller, but making them a stereo pair, then taking one away (garden/travel) does result in having to re-create the stereo pair again - all rather clunky.

I tend to use ad-hoc grouping a Roam with another unit in a different way - have the Roam in near proximity to the unit you want to group with, hold the Play button down on the Roam for about one second and it will group itself with the nearest unit.
I have tried this while playing through Roon to a pair of Sonos One’s on S2 and it works (but very much doubt it will with S1 units).

Yeah I tried that also but that’s only works with S2. I can group them by the controller but it refuses to play, it’s loosing at least one of the devices and then I can only play through moth the roams or the connect. I’ll keep on trying but I am afraid I’ll have to upgrade the connect eventually. Thanks anyway.

Hi Paul, I know this post was a little while ago but can you please just clarify what you said there for me - Are you saying that a Sonos system which has been upgraded to a ‘split’ S1 and S2 set of devices (from Sonos controller’s perspective) doesn’t impact on how they can still be used with Roon?

It’s funny, as I know Sonos backtracked slightly on some of their policies after the original announcements but I was one of the very upset, very long standing Sonos customers who ditched using the Sonos controller and bought a Roon lifetime subscription shortly after Sonos gave us the ultimatum about ‘legacy’ products that were ‘no longer compatible’ - even though most of the hardware specs were identical. Anyway, I left all my Sonos zones running on S1 and they call work fine with Roon of course.

However I was considering upgrading those of my S2 compatible devices (Sonos Move and Sonos One players) to see if Roon could deliver 24bit music to them (as I gather now works beyond just Amazon music using Sonos controller). So, if that means the Sonos App has to see them as split S1 and S2 systems, but Roon still just sees them all as available endpoints regardless then that’s great news. If you can confirm that would be great :+1:

Stephen, did you brave it and try this?
I need to upgrade to S2 so my wife can use a new Roam SL but don’t want to lose the ability to control two of the S1 only Connects through Roon.

Hi Rob,

Sorry for the slow response. No, I didn’t try it and whilst everything had been working fine, all of a sudden now I can no longer see any of my Sonos devices as available in Roon other than as Airplay devices.

When I did a quick search to see if it was a known issue I found that it was - but that was from May 2021 and a temporary known issue with version 1.8! Anyway, no idea of it’s the same issue recurring, or something else. How are yours doing just now?

[EDIT: Never mind my question - No sooner had I posted this, the problem ‘magically’ disappeared after restarting Roon Core (running on Mac Mini) and seems fine, for now at least. Will revisit this post if it comes back again]

[EDIT 2: Mmmm, seems like I have a problem after all. After editing my post yesterday to say all my Sonos zone players reappeared in Roon after rebooting Roon core, now they’ve all disappeared again. As mentioned, this has been a known issue before in a previous update (not that I experience it at that time) but it now seems to have resurfaced and needs reporting to #support to see if they’re aware and have a fix.

If anyone from #support reads this, would be grateful for a comment :+1:]