Sparky: No sound on DAC on USB 2.0 ports

(Andy Spinks) #1

I’m attempting to use a Sparky with Dietpi to feed multiple USB DACs. The one DAC I have that is not USB powered (It has its own power supply) works fine on the USB 3.0 and USB 2.0 ports. However, my USB powered DACs (e.g., Dragonfly Black) only work on the USB 3.0 port.

When connected to the USB 2.0 ports, the Dragonfly DACs show up both in Roon and in ALSA mixer, but no sound comes out. Roon shows a lossless RAAT signal path, and the green LED on the Dragonfly even comes on, indicating that it is playing at 44.1. I’ve tried switching the audio settings in Dietpi from “usb dac” to “usb 1.1 dac” but that didn’t resolve the problem.

Any ideas, @Dan_Knight or @ALLO_audio_boards?

(Andy Spinks) #2

DietPi is the latest version. Downloaded and flashed last night, first boot and updated today. I initially installed Shairplay along with Roon Bridge but then uninstalled shairplay.

(Mr Fix It ) #3

@Andy_Spinks What powersupply are you using…is it up to scratch current delivery wise? 5V 2.5A is for the RPi … not sure if the spec for the Sparky is above or on par with that.

(Peter Lie) #4

Try inserting a USB hub with power supply between the USB 2.0 port and the DragonFly.

(Andy Spinks) #5

Canakit 5v 2,5A

(Matt Kuehn) #6

I picked up an Allo USBridge earlier this week and noticed the same thing. My intention was to run a Pro-Ject S2 from the ‘good’ USB port on the daughter board and a small SMSL amp with USB DAC from one of the other USB ports.

When using the rear 2.0 ports the SMSL LCD screen shows that it’s locking on to the bitrate of the file being played through Roon but no audio comes out. The USB 3.0 on the side works no problem. I ended up moving the SMSL DAC to a Pi that I had handy.

My Allo was being powered by an iFi AC->DC switching power supply.

1 Like
(Andy Spinks) #7

So I did some additional experiments today:

  1. Did a clean install of DietPi on a bigger, faster micro SD card. Installed only Roon Bridge. Set audio device to usb-dac and changed only localization, time zone, hostname, and root password.

  2. Tried connecting one bus-powered USB DAC at a time to the USB 2.0 port (rebooting on between each):

So it IS possible for a bus-powered DAC to work on these ports!

  1. Tried a different power supply (2A iPad charger with the most high-current micro USB cable I own). No change.

  2. Tried connecting two different externally powered USB 2.0 hubs in between the USB 2.0 ports on the Sparky and the Dragonfly Black. In both cases, the red LED lit on the DAC, indicating power on standby. It never showed up in Roon as an endpoint that could be enabled, even after rebooting.

  3. Tried connecting DACs to a bus-powered USB 3 hub to the Sparky USB 3 port. Dragonfly Black came on and played, second USB DAC was recognized but would not play.

  4. Tried connecting Dragonfly Black to USB 3 port, $20 Amazon DAC to USB 2, and externally-powered JLS ODAC to USB 2. I had just enough time to verify that all three would play music before the wife took over the living room to watch Vikings.

TL;DR: It is possible for a bus-powered DAC to work on the USB 2.0 ports. It doesn’t seem that power is the issue, but if it is, an externally-powered hub doesn’t seem to help. I have a workaround in place, but with different DACs/ports than I was planning to use.

What should I try next?

(Andy Spinks) #8

OK, my workaround stopped working, so I wasted a beautiful spring Friday afternoon trying other options. DietPi GUI, Volumio, Ubuntu… The Dragonfly just won’t work on the USB 2 ports of the Sparky. Sparky is fine for one DAC, but not for more than that. I’ve ordered the new Pi 3 B+, so we’ll see how that goes. I guess if I keep buying SBCs, each DAC can have its own.

On the plus side, I now know how to install Roon Bridge from a Linux terminal…