Spotify Connect, no sound, or skipping continously RopieeeXL

Roon, Airplay works fine.
Spotify as title says ; no sound, or skipping songs continously
Edit : sometimes just “stuck”, song not starting)
(Spotify® Premium Family member account)
Setup in screenshots
This goes for either playing from PC, iPhone or iPad

Have tried all the possible settings and configs
(HAT, Hostname, Volume control HW,SW, Off, With and w/out username/password, logged out, deleted app, cleared cache etc)
Feedback identifier: 3b2efb70959130e6

I know this a Roon forum, and im asking a Spotify Connect question.
But this the closest thing to a Ropieeeforum i know…

@spockfish : any chance you could have a quick look? If only to state fault at my end or software

This is a known issue for people located in Scandinavia. Looking at your name I assume you are located there… Am I right?

Anyways, here’s the issue: Suddenly unable to play any tracks · Issue #972 · librespot-org/librespot · GitHub

It has something to do with the Spotify infrastructure in those countries, unfortunately.
There’s a hack mentioned that I can try out…

I’ll let you know when I’ve got something available (in the beta channel).


Scandinavia, correct.
Thanks for responding, now i know its an external issue.
Ill set my RPi to Beta update channel


I’ve pushed an update to the beta channel that has the hack mentioned in the ticket.
Can take a while (up to an hour) before the update appears in RoPieee. Let me know how it goes!


It works!
At first, there was a (beta) update that didnt do anything regarding the skippping (0396?),
but immediately after there was an update (0405) and it worked from the start.
Playing songs as i write this. Have tried from iPhone, iPad and desktop Spotify clients.
Awesome reponse time and problem solving.
Donation placed!


FYI: Librespot got a builtin workaround for this in the latest release, so when you update to that release the ropieee XL specific hack could probably be removed: Release v0.4.2 · librespot-org/librespot · GitHub

1 Like