Spotty linkage between OpticalR., PS Audio DAC, ROON

I use an OpticalRendu lite and am finding it a little unpredictable on Roon. It usually works when I turn on my system but there are times when I turn on and ROON does not see it. I power the OptticalR on/off, I power ROON on/off!, I power my DAC on/off. Some combination of all of that works…

But what could the issue be? @Jesus_Rodriguez

Might this be a flow control issue? It seems that when it happens, only turning on/off the OpticalR and the PS Audio DAC DirStream Jr. is not sufficient. I have success when i eventually also restart Roon’s Core. At this point i don’t have a clear view of what actual gets the OpticalR seen by Roon again.

The Rendu needs to sees your USB device (DAC or digital converter) before it will show up in Roon or other servers for playback.

To verify that the Rendu sees your USB device follow these steps:
1 Go to Settings and click on the output protocol you want to use and press Save.
2. To verify that the Rendu sees your USB device go to Apps / DAC Diagnostics.
2a. If your USB device is not listed you may have to remove and reconnect the USB cable, then refresh the page.
2b. If your USB device is still not listed try power cycling (remove and reconnect the power cables) the USB device followed by power cycling (remove and reconnect the power cables) the Rendu and then go to Apps / DAC Diagnostics refreshing the page to get the latest data.
3. Now go to your server’s Settings and Enable the Rendu for playback.

Note: These steps may be required after an update of the SonicOrbiter operating system.

Noted with thanks. I will keep this in mind and advise on how this evolves….

I have an update on the behavior and would appreciate further guidance. I powered down everything but Roon Core overnight. In the morning i had trouble streaming. Here are the details:

• DAS & Pre out of standby
• Powered up amp / streamer
• Roon live radio on and working
• Switched to Roon playlist.
• No music playing
• Sonic Orbit. (SO) sees DAC
• I restart Roon Ready from SO- no effect
• I “reboot” from SO System - no effect
• DAC is no longer seen in SO
• I power on/off DAC
• DAC is now seen in SO
• I open Roon on ipad. The OS app sees OptRendu but does not play. It sees and skips each track. It will not play radio either.
• I restart Roon at the Core
• Ipad ROON sees OpticalR. but no music - tracks being skipped
• In SO I Refresh App /DAC diagnostics/ refresh status It sees the DAC. but no music played
• Turn on/off DAC
• Refresh status in SO. It sees the DAC
• Music plays (live radio)…
• 20m later…Playlist ends and I selected a new play list. Same problem as described above - no music playing and tracks seen and skipped.
• Restart ROON at the Core -Same problem - OptRendu seen, but tracks skipped
• Restart DAC
• Music plays

With this more detailed info, can you @Jesus_Rodriguez advise on the issue and how it might be fixed. SO software in OptR. is 2.8. If you want to take off line, that is fine too. Which ever you prefer.

I’ve had the same issue a couple more times this week but have simplified the solution. Still, the solution is not a fix so would be grateful for feedback and suggestions.

…From a cold start, all up and running and listening to Playlists from Tidal over Roon.
…Switched to a new playlist and no music. OptRendu is seen but music just skips forward. It tries to play but does not and skips to the next song, which is unplayable…
…Turned off DAC, closed Roon on the core PC, turn on Roon, turned on DAC. Same problem
…turned on/off Dac again
…music returned.

Any thoughts on what the issue is? The OpticalRendu is the new piece of equipment. Prior using Bridge II in PS DS Jr and no issue.

Ugh. Just went to have a listen. The above fox didn’t work. I turned on/off Roon twice, the DAC 4-5 and the streamer twice.

What set this off was seeing music playing in Roon (eq graphic moving next to track) but no sound. Then I turned on/off Roon and the DAC but no joy. Eventually the signal was lost from the OpticalR to the DAC. About 20 min later and several toggles, it work. No fun.

The Rendu needs to be in Roon Ready output mode (step 1 above). The Rendu needs to see the DAC (step 2 above). Roon needs to connect to the Rendu (step 3 above). These are set and forget.

You can update the Rendu just in case, but if you can manage the Rendu and it sees your DAC the is issue is likely elsewhere. I would reinstall Roon on your server. If the issue persists then you need to open a support ticket with Roon.
You can submit a support ticket here.

Thank you Jesus. The OptRendu does see the DAC, but often the handshake fails. Since it is seen, and it is a plug and forget relationship, I understand that your view is that the Opt Rendu is not the issue - it is doing what it is supposed to! Very well, I will seek support from Roon. Perhaps a reinstall is all that is necessary to keep the handshake warm and lasting. I will report back. Thank you for your attention.

@Jesus_Rodriguez (thought it would be good to let you know where we are with this.
If you’d like to move to a direct message, please share your information).

Dear Roon, Jesus Rodriguez of Sonore suggested i get in touch with you. Rather than rewrite my problem, probably better to direct you to the forum discussion.

Please see:

Spotty linkage between OpticalR., PS Audio DAC, ROON

As an update, i thought i was making progress by sequencing on the DAC and PRE AMP and then the OptRendu… but i guess not. The most recent experience was:

  1. all turned on in the sequence above

  2. pressed play on previously paused playlist

  3. It worked

  4. I added a different playlist to the Q

  5. When the playlist went to the next song, it didn’t see it and skipped and then it kept skipping.

  6. I spend 30min working different sequences of trying to get music and despite getting the ORendu recognized, Roon continued to skip.

I have gone back to the Bridge II in the DAC, and all is fine. Still - would like to use the OR.

1 Like

I am a Rendu user as well, so thanks for posting this information.


Per feedback from ROON, I am flagging @support for their attention and guidance on this issue.

@support - gentle bump please.

Hi @hshrader ,

Thanks for the flag here. We spoke to our hardware team regarding this behavior and this sounds like it could be an issue with the USB connectivity on your PS Audio DAC. There may be a firmware update on the PS Audio that can help according to the PS Audio update notes, can you please confirm if your PS Audio is on the latest firmware? Thanks!

The short answer is no, but. :slight_smile:

The DAC’s firmware is updated now and again by PS Audio via its programable DAC chips in an attempt to squeeze out better sound. PS Audio says that any one of the last few updates are fine to use – it is up to the user as what he/she thinks sounds best. I am pretty confident that the current update would not affect the USB connection or fix an issue is as severe as i am experiencing.

I am running the penultimate update and have written to PS Audio to share the problem and your initial query for their feedback.

1 Like

@Support - I have updated to the latest firmware at PS Audio. Unfortunately, no change in behavior. It is rather maddening to try to get the stream to work. Is there anything you can do to determine if ROON may be at fault.

My uninformed option it is about the handshake between the ORendu and the DAC. The Bridge II on the DAC is fine with Roon.

On a side note, since that major update where some lost access to corrupted files, Roon takes on average of 65-75 sec to boot. Is this normal? I have a 16gig/ i5 gen7 chip PC. Nothing else is running while ROON is being booted.

Hello @hshrader ,

Thanks for those additional details!

Yes, this is most likely the case here, if Roon is working properly when bypassing the OpticalRendu, then the issue is most likely with the OpticalRendu itself. Roon uses RAAT to talk to both the OpticalRendu and the PSAudio, so if the issues only happen with the OpticalRendu in the mix, it is likely the source of the issue. I suggest reaching out to Sonore support for further troubleshooting, thank you.

I have an opticalRendu and PS Audio Directstream DAC and from time to time experience the problem as described here. The solution for my system is simple if slightly annoying, turn off the Rendu & DAC, turn on the Rendu and let it get running and then turn on the DAC. Seems to fix the problem and as it only comes up from time to time I’ve not spent any additional effort trying to troubleshoot.