Squeezebox touch no now-playing screen displayed

Why is the device setting of logitech devices shorted down and isn’t it possible anymore to set some (display) preferences. Like it was shown and explained in https://kb.roonlabs.com/Squeezebox_Setup) I do understand that’s its all about the music. But the previous setting where somewhat easier on the eye. As it is now squeezebox is working fine but no now playing screen with coverart but just the default logitech clock is displayed. What’s the reason this was changed and will it be restored in a future/feature update.

I still have the ‘now playing’ screen with cover art.
Sometimes indeed, it falls away after a period of not playing music.
Most of the times, the display is alright again after starting to play a new track.

In a small number of cases, I have to reboot the SQT to get the Now Playing screen back.

Did you restart your SQT completezly, i.e. power off - power on?

Dirk

Never have seen a now playing screen on the touch so far. Rebooted a few times. I found no ways to achieve any changes. Very strange that all the settings in the previous version(s) have disappeared.

I just got my Squeezebox playing via Roon within the last 10 minutes, and I can’t seem to enable Now Playing at all…

Yes… Using the squeezebox user-interface is completely useless. And it only displays the time. Displaying the time is normaly (on LMS) only in idle/off-state.
So just like me just enjoy the music… :wink:

OK, I got it working. I was thinking that I could invoke the Now Playing screen by using the Touch remote and selecting Now Playing. That has still never worked.

Instead I set the options that I wanted under Settings>Screen, and it started working by itself after a few minutes.

What setting did you change / enable.