Squeezebox Touch suddenly no longer seen by Roon [Solved - Windows Firewall Settings]

Everything was working perfectly until it wasn’t. Tried using my system tonight and songs were taking a very long time to start, and when they did, they cut in and out. Not sure if my router or computer or SBT (squeezebox touch) needed a restart, I restarted them all. And now Roon does not see the SBT. Router is working perfectly, everything I own has internet right now, the laptop I use as roon core works perfectly and has internet, the SBT also has internet and can stream music off the net, but will no longer communicate with Roon. So frustrating. Has been working perfectly since I set it up a month ago.

My system is relatively simple. Laptop as roon core, SBT as endpoint. Both independently getting internet from my network, they just can’t see each other. And they did half an hour ago. The only thing that changed between the crappy connection I had earlier tonight and the lack of connection I have now is I restarted everything. Help please @support

LMS running somewhere on the network?

No other computer in the house has LMS or Roon on it. One thing I was thinking this morning is that my computer needed an update during its restart procedure. What kinds of things can I check that might have changed during an update? I have already checked my network firewall settings.

Make sure Squeezebox support is entangled in Roon. Restart the Touch and Roon Core thereafter. If still no joy I’m out of options short of seeing whether the Touch is responsive to LMS or faulty.

make sure no firewall settings are on

Perhaps the IP of the server changed due to the reboot? This has confused my Squeezebox Radio before now.

Hello @Dustin_Kalthoff,

Thanks for contacting support and sorry for the slight delay in getting back to you here. I would like to confirm a few things:

  • Is Squeezebox support enabled in Roon Settings -> Setup?

  • Are you Squeezebox Touch on the latest firmware?

  • Would you be willing to do a factory reset on your squeezebox devices to see if that helps?

  • Do you have a NAS running Squeezecenter by any chance?

  • Please take a look at this post: Squeezebox Touch not seen by Roon, do those instructions help?

Please let me know when possible.



It looks like the windows update was at fault. Despite my best attempts to disable the firewall and restart everything, what seems to have worked is I reset all my computer internet firewall settings to default, then disabled the firewall for my private home internet connection - which was disabled before I reset the firewall to default settings - but that’s the only thing I changed.

Weird, but glad it’s all working excellent again.

1 Like

Thanks for the update @Dustin_Kalthoff, it does seem like the Windows update reset your firewall setting somewhere and I’m glad that you were able to get it working again with the default settings and then disable.

Thanks again for contacting support and letting us know this, I wish you a pleasant listening expereince!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.