Squeezebox Touch unable to play 24/192 and some 24/96

Hi,

I’ve just set up my Touch as an endpoint. It uses 7.8 firmware and is attached via a usb cable into a Dacmagic 100. I have also installed EDO. I use Qobuz. When I try to play 24/192 and some 24/96 albums there are drop outs. Anybody have any ideas as to how I can sort this. The Server is on a MacBook 2009 with an SSD and 4gb of RAM. Do I need more RAM?

How is the Touch connected to the network - wi-fi or ethernet? I’ve found that the wi-fi in the Touch can be a little quirky at times.

HI Easysqueezy

Some things to try

  1. As Ralph said use Ethernet rather than WiFi
  2. Under Advanced Settings for the Touch, Turn on “Flac Compression” and see if that helps.

I’m unfamiliar with this setting. Exactly what does it do?

And more importantly, where the heck is the setting located because I could not find it.

Thanks!

Either , (Settings/Audio or if it is the current chosen endpoint click the volume Icon), then click on the gear, choose Device Settings, at the bottom choose Advanced Settings, scroll down a bit and it should be there.

That option sends the Squeezebox endpoint a compressed FLAC stream instead of the decoded PCM stream. The FLAC stream is smaller and see will be easier to stream.

Thanks!

I was looking at the settings on the Touch itself and not on Roon. Turns out that I had the use flac compression setting turned on anyway.

:smiley:. Then try turning it off and see if it makes a difference.

I’ll try Ethernet tomorrow. Thanks for your advice.

Nah, the Touch is located in a bad spot Wi-Fi wise and sometimes, depending on how the router is feeling, I can stream 88.2 or 96 kHz files with no problems and other times the Touch just skips, drops out, etc. Ethernet is the way to go whenever and wherever possible.

For anything above 48/24, the Touch requires a USB Hub between it and the DAC. This is due to a limitation in the original hardware was not even supposed to have USB as an output device. Also, do you have the “no hub” workaround activated in the EDO settings of the Touch. This will allow Redbook playback without problems. With a hub installed turn this off again.

Not true, at least when not using the EDO modification. The coax or optical digital output and the internal DAC will all handle up to 24bit/96kHz digital audio files, in either wav or flac format.

2 Likes

True, I was assuming USB because of the mention of 192/24.

Got it! My mistake.

Well.Tried with usb hub but still drop outs sadly. Now using my SSD’d 2009 MacBook.No problems with 24/192 playback and I installed Insomnia so I can continue to use it with the lid closed. Operated by remote through my IPad Air.

Two tips here.

One, the SB players will all have streaming issues going much above 96/24 on wireless, as you are getting closer to saturating their elderly G-band connection. At 192 kHz, you are right at the practical limit of a wireless connection on these. Use an Ethernet connection with higher bitrate HD streams. You won’t regret it.

Second, my experience with the SB players is that the SPDIF output is the most stable as you pass through higher bitrates to an outboard DAC. Unless you need the ground loop isolation of an optical link, I would go with a coaxial connection first to your DAC. Toslink will start to experience increasing dropouts once above 88/24. And there is no need to futz with a USB connection with a Touch once EDO is setup. Use a good quality 1.5m digital coax cable, and you should be good to go up to 192khz.

The Touch by default is setup to natively decode a FLAC stream, so don’t change anything there. Occasionally, some of the SB players (the Transporter in particular) will choke on a non-standard FLAC compassion rate file. Re-encoding the file to a less aggressive FLAC compression rate will solve that issue whenever it arises.

In any event, I do not recommend networking any server machine via wireless. The server machine should be on Ethernet for best performance. You may be able to pull it off with one client most of the time, but other machine tasks will inevitably disrupt a wireless stream, causing client dropouts.

Lastly, be sure to turn off the local analog outputs in EDO if you are using an outboard DAC.