Stable release 2.526 (2020/06/13)


Time for another update!

Stuff all over the place, from supporting the new Pi 4 “8 GB” model to switching to a different UPnP renderer on XL.

Here’s the changelog (which you can find on as well):

  • NEW: support for the Pi 4 “8 GB” model
  • NEW: support for Realtek rtl8723bu driver (looking at you Pro-Ject Stream Box S2 Ultra)
  • NEW: support for Hifiberry DAC+ DSP and DAC2 HD
  • NEW: [RoPieeeXL] support for OpenHome with UPnP/DLNA
  • NEW: [RoPieeeXL] DSD capability with UPnP/DLNA
  • IMPROV: better regulatory domain handling with WiFi
  • IMPROV: [RoPieeeXL] update HQPlayer NAA
  • IMPROV: [RoPieeeXL] update Squeezelite
  • IMPROV: [RoPieeeXL] update Librespot (Spotify)
  • IMPROV: [RoPieeeXL] support for username/password authentication with Librespot
  • IMPROV: [RoPieeeXL] remove ‘auto’ option for output selection
  • IMPROV: reworked device discovery
  • IMPROV: reworked update mechanism



So this is the first update published since I built my one RoPieeeXL box a couple weeks ago. Putting aside I am on this forum regularly, and so will see your posts here, I don’t see any visual indication of an update on the touchscreen. I only see the “update available” when I connect to the web interface. Am I just blind? :slight_smile: Or if it’s not on the touchscreen, maybe consider a feature request to add an “update available” indicator there. Would make it much more discoverable for people that don’t check Roon’s forum multiple times a day…

Just tried the new UPnP/DLNA support with the native Qobuz application. (Which I don’t actually use, other than to test DLNA – I do all my actual listening via Roon.) On the plus side, it actually plays. On the negative side, the volume is barely audible. It’s easily only one quarter the volume of what Roon plays at when set to max in Qobuz. I have volume disabled in the RoPieeeXL config page (the DAC/AMP combo doesn’t do USB volume, anyway – I control it via the physical volume knob on the AMP). Tailing the upmpdcli log (“journalctl --no-pager -f -u upmpdcli”) as it plays and I move the Qobuz application’s volume slider up and down, I don’t see anything obvious related to volume.

I don’t have any other DLNA source apps to test with to see if this is specific to Qobuz (who outright state that their DLNA implementation is beta) or the new DNLA server itself.

I sent feedback with ID 788f2d4e5cdc0267.

@cwichura, last year there was also a suggestion to blink the LED to indicate an update, for those that do not reboot and update automatically (and leave the LED on — I don’t). I like the idea of a simple status icon on the display, actually.

EDIT: I should have been more clear that Harry also implemented the flashing LED functionality in v.359:

2019/09/10 (359)

  • NEW: [RoPieeeXL] Spotify support
  • NEW: add LED functionality for ‘blink on update’
  • IMPROV: disable reboot/shutdown button while updating

@spockfish, so this means that people (after updating) will need to select the output (USB or HAT), save, and reboot, as the setting now defaults to “Off”. Is this a correct understanding?

Thanks as always.

Yes that’s correct.

The ‘auto’ setting caused a lot of confusion. Now it’s very clear what to expect.


So I guess if you have several dacs and a hat then what you have to do is decide? Or will it support everything?

Also when will this catch up in the beta channels?

You need to pick with those services where it is exposed. For Roon and HQ you select the output server side.

I’ll update the beta channel later tonight, I first have to take care of the BBQ :yum:



I’m using only the UPnP/DLNA function of RoPieeeXL (Audio output USB)
the upnp control point is Audionet RCP (free) on windows 10 (
this worked perfect from release 2.428 to 2.493

the latest update to 2.526 doesn’t work anymore for me (no UPnP Renderer found)

the same problem with eezupnp on windows 10

another PC shows the same behavior

can you please check the UPnP functionality


ps how can I downgrade provisionally to version 2.493

Enjoy yr BBQ…so basically can only now support 1 streaming service per output? ie say Spotify to a HAT then it will only be able to play to the HAT but Roon can still chose whichever output is available.

I might be one of the only Ropieee users that sometimes has more than one USB DAC and a HAT connected. But for the most part its normally one.

Check your output setting.


Basically this is the confusing part with the previous ‘auto’ setting.
Output for those services are static, you must explictely say which sound card to use. The only thing the ‘auto’ setting did was, at configuration time, pick one and prefer USB before a HAT.

So if you started with an USB DAC powered on, and left it on ‘auto’, it worked, but if you then disabled the USB DAC it stopped working. So from a functional perspective nothing has changed, but the notion that you need to make a choice is now explicit.

So if you want to make a switch during a listening session you need to change this setting.

Hopes this clarifies it a bit better then the one-liner in the changelog :wink:


1 Like

Whoa, support for Stream Box would be fantastic! Even without rtl8723bu support. :wink:

Best regards,

Unless you need to support this chip for a USB port.

Best regards,

Perfect, many thanks for this update.

@spockfish Harry, there is a typo on the web GUI splash screen. I suspect you meant “Your device”?

1 Like

What is “Volume Level”?