Stable release 2018/01/17 (083)


This is the first maintenance release of 2018!

It’s very small though, no exciting features :wink:

  • NEW: native DSD for the Mytek Manhattan
  • NEW: native DSD for the Mytek Brooklyn DAC+ (second generation)
  • IMPROVEMENT: bump Linux kernel to 4.6.70

Due to an extremely busy schedule (working on a secret project ;-)) it has been rather quiet lately, but no worries.

I’d like to thank everyone for their support over the last year! It has been a fun ride :smile:

Enjoy the music!


Interesting … and thanks for all the work on RoPieee.

Great work Harry…hope you have a great 2018 and find some time in your busy schedule to make some tweaks and upgrades here and there to Ropieee too. :smile:

Roon related secret project?:scream::stuck_out_tongue_closed_eyes:

Everything is very stable Harry. You can see very few issues raised these days. That means lots of happy users :grin:

You’ve done an incredible job last year to get it to this point.

I’m happy for you that RoPieee has been getting some good exposure beyond the forums, like by Darko and the always entertaining Hanz B.

Many thanks, as always :slight_smile:

I have just updated my Pi with the latest Ropieee version but have some problems @dabassgoesboomboom . Everything workes fine with Roon but I cant connect to the WEB GUI on the IP adress that Ropieee has. Tried to restart everything but no luck, any idea what might be wrong?

Harry should be able to sort it for you

But even http://ropieee.local/ doesn’t work for you?

I presume mine is updated to the last version (83) even if WEB GUI display previous version (78) ?

That never worked at my place, probably because my pi is plugged on a second router/switch (Fritzbox) that is bridged to another Fritzbox.
So, I enter the router to check the IP address of the pi, that’s for me the only way to get to the GUI.
@Fredrik_Andersson are you sure you have the correct IP (not that your router has privided another one)?

Saw that at my place as well. Just restart the pi. Then I got th right version number.

Nope that wont work either…have restarted my whole network twice and Ropieee starts as I should and Roon works as usual but no access through the IP adress and that have always worked and did so before I updated. Any thoughts @spockfish

I have the correct IP adress, Ropieee showed it before I enable control in Roon and I have checked my Router so yes I am 100% shure the IP is correct.

Then I’m, as puzzled as you are.
Maybe you could try another device (phone, tablet) to see if it makes a difference.
Hopefully Harry has your solution.

Hmmm… this sounds as if the web server isn’t running at all…

Are you familiair with SSH and command line stuff?

No I am not familiair to that. But I can give it a shot if it is something you think will work.

Hi @spockfish, I have 2 RoPieees running, one wired which updated OK and one wireless which did not update.
I’ll check again tomorrow.

Edit: rebooted twice and I’m on v083 on the wireless RoPieee too.

Web services of my three Ropieees (ropiee1, ropieee2 and ropieee3) stopped just after applying the stable release (083). I can’t access to those Ropieees from any web browsers on any home computers. Roon bridge function (music out) and 7inch display are working fine. SSH is also fine to all.

wow :-1:

this is a very bad start of the year I would say. I’ve got it to on one of my machines, so I’m investigating it right now…

Well sort of a good thing that you also have the problem but then a bad thing if it is not an easy fix :frowning_face:

There’s nothing Harry can’t fix! :sunglasses:

1 Like

Ok quick update: this is an upstream bug ("it’s not my fault :wink: "), in this case in Node.js because that’s used for the webpage. It’s being worked on, and as soon as there’s a solution I’ll (try to) fix this via RoPieee’s emergency fix system.