Stable release 2018/11/18 (226)


A new release on this cold day. Not a big release, but a feature that has been asked for multiple times: support for USB wifi dongles!

For now this only works with the Realtek chipset (the Wifi dongle is one of them), but I’ll add more when it comes to it.

This is all auto-detect, so you basically only need to configure it in the webpage. If a dongle is detected on a Pi 3 with internal wifi, the dongle is being selected.

Furthermore it contains a fix for wifi when using special characters in a WPA passphrase (@G_P).

For a full changelog you can visit the webpage at



You might want to edit that title to say 225 not 215. :grinning:


Thanks @John_Aiello!

Harry, I seemed to have lost wireless capability with this release. I have tried re-flashing (using a prior downloaded image, as I can’t seem to get Etcher to make new images), and after turning wireless on the SSID disappears.

Any hints?

Feedback: 17187608af61bb06

Hi Nathan,

It can’t discover your network.
Just to be sure: you’re using the on-board wifi right?
And have you tried completing the sequence first? So save it in the situation above, then go back to the network tab and check again?

Hi Harry,

Yes, on-board wifi. The steps I take:

  1. Enable wi-fi. Save. Reboot.
  2. Select SSID from drop down. Add password. Save (password is correct). Reboot.
  3. Pi takes a long time to reboot.
  4. Upon reboot, the SSID is blank in the gui, and I am unable to select any SSID (eg to re-select it).

Anything I should look at?



Can you look into:


blacklist brcmfmac

sh… that’s not good.

Remove that file and reboot.

1 Like

Bingo. :slight_smile:

Wi-fi (internal) now working.

yeah. we’ll, I’m not that happy :wink:

Anyways, I found out what the issue is, so I’ll push an update out in a few minutes.

1 Like

Yeah, I know. When I saw the contents, I said “F*&%, that’s why”.

Thanks Harry.

Yeah. It goes wrong when you insert an external dongle.
It tries to figure out which one you’re running, and blacklists the other one.
But if you ran the script twice (what happens during the config step), it blacklists the wrong one.

I guess I need to change my test procedure. I always skip the reboot when I’m configuring wireless :wink:

1 Like

fix is out.

V226. Internal wi-fi confirmed good.

1 Like