Stable release 2019/05/18 (262)


Fairly small release, but I really wanted to switch to the 4.19 kernel.
This has been running on my system for quite some time now without any issues, so let’s do this.
For the rest some ‘under the hood’ changes in preparation for RopieeeXL.

Here’s the changelog:

  • NEW: switch to Linux kernel 4.19
  • FIX: handle backslashes in wireless passwords



Got the update and threw my wifi off. Connected up the ethernet, logged in and the SSID is missing and I can not see any drop-down. Tried to uncheck wifi and remove password. Save changes does not work.

hmm? standard WiFi or with a dongle?

Standard onboard wifi. Was working earlier this morning. Relocated the Allo, plugged it back in and nothing.

Can i grab 258 and reflash to test?

That’s weird. Working here fine.

I have not uploaded the new images yet, but you can download the latest available one. It will update during installation.

af19726c7f4f0a0d Here’s my log. Trying a few other things

Can you go into the web page and enter your wifi password again?

Yes but the SSID is blank. Reflashed and trying again

And you can’t select one?

correct, no drop-down appears when I click the field

yeah I see it. it can’t find any wifi network

I’m uploading the new images. will be there in 10 min.

reflash worked. Able to configure now.

Back in the system with 262 and all’s good.

1 Like

I have installed this update and everything is working as expected. Thanks for your great software.

I might be doing something wrong, but for every Ropieee upgrade, I end up rebooting the Ropieee (literally) five times.

The option is set to check for updates on reboot. I would expect then that two reboots are required; first to trigger the check for the upgrade (I assume after the reboot has actually taken place) and the second time to activate the new version that got checked for (and downloaded) after the first reboot.

I can guess that what happens is that perhaps indeed on the first update a check is made for a new Ropieee version, but that the download and install of said new version takes… an unknown amount of time. I sit there rebooting Ropieee like a madman, and for all I know I could reboot it 10 times and still not get an update, because there is no indication that there is an update, and that if there is an update, that the update is ready to be installed and activated.

But it works, after 5 reboots, I have Ropieee 262! :smiley:


I hear you. I’m going to change this, so even if you have set the update mechanism to ‘automatic’ it will show in the webpage that:

  • an update is being pulled in (and yes, depending on the size that could take some serious time!)
  • a reboot is required

So in the near future you can just check the website to see it 's still working. No need anymore for the 10 reboots :wink:



well, this update jumped the kernel on a minor level. That also requires firmware stuff to be updated as well, hence the second reboot.

The good news is that this kernel jump on a minor level only happens once a year (or even less). I’m thinking of a way to make these kind of updates (that require an actual reboot to work) manually.

Thanks for the info Harry, fully understand, all good!

wi-fi glitch: my Roon Display (Pi 3B+, internal wi-fi) did not reconnect after this 2.6.2 update
turned it off then on again and all is fine now

no issue, instead, with my wired Allo DigiOne (a Pi 3B+ too)

just FIY, Harry :wink:

New version seems to be working fine for me. No issues updating.

Same for me, it just updated automatically in working fine, thank you.