Stable release 2019/09/10 (359)

(Harry ten Berge) #1

Hi,

I’ve released an update today which brings Spotify support to RoPieeeXL.

This was sitting in beta for quite a while, so I thought it was time.
For the rest a rather calm release, here’s the changelog:

  • NEW: [RoPieeeXL] Spotify support
  • NEW: add LED functionality for ‘blink on update’
  • IMPROV: disable reboot/shutdown button while updating

Enjoy!

9 Likes
(Mr Fix It ) #2

I find myself playing Spotify as much as Roon these days…my Mrs is far more in the Spotify camp…Mind you not that its out in the stable channel I can stop beating on it. Very to have tho…only thing I miss is track info on my displays.

Great job Harry

#3

I also would like to thank you to keep the “normal” and “lean” Roon version separate to the XL version. I will donate also to give you some “thank you” pocket wise :smiley:

1 Like
(Tim) #4

@spockfish

Signed in to two of my Pi’s via the web interface ( versions 337 and 352 ) today and was informed an update was available. I started the update process on both and got your standard message" Your device is busy updating… Do not turn it off!" on the General tab.

It’s now been over 30 minutes and neither display has updated. I refreshed both browser tabs and then got messages that both systems needed to reboot.

Just letting you know in case the reboot message should have been displayed automatically. If not seems like a nice feature to implement.

Tim

(Harry ten Berge) #5

yeah working on dynamic update for this

1 Like
(Tim) #6

Great … Thanks!

(Mr Fix It ) #7

Love to see the devices sortable by Ip or name too :slight_smile: thought that was done?

(Harry ten Berge) #8

no sorry mate. it will happen. eventually :wink:

(Peter Trenner) #9

Hello Harry, what do I have to do, to play spotify? I updated and I am running on XL at the moment. But neither I can see the Raspberry in Spotify nor can I play via DLNA from bubble or jriver. Maybe I do something wrong?

Best regards

Peter

(Jamie Tudor) #10

One suggestion for this release (and RopieeeXL in general) - can you add an option to disable Spotify, Airplay and DLNA?

I imagine there are plenty of people like me who want to use one or two of these features but not the others. I’d like to be able to turn Spotify and DLNA off.

Cheers
Jamie

(Roger Cliffe) #11

Thank you very much for this addition. It’s working well for me here.

(Nathan Wilkes) #12

Harry, I updated the beginner’s guide, and included a chart for RoPieee vs RoPieeeXL. Let me know if anything needs to be changed.

1 Like
(Mr Fix It ) #13

Fantastic effort @Nathan_Wilkes … My only comment is that while you noted the RPi 4 in the document all images pertain to the 2/3 physically and perhaps a note to that effect is appropriate :wink: - and its a very minor oversight at that.

Are you going to add perhaps an XL addendum?

(Nathan Wilkes) #14

I included a chart of the differences, but do you think additional XL material would be helpful? If so, what are some of the key points?

(Mr Fix It ) #15

Well maybe at least the bit about if you have multiple outputs available to set the HAT or USB options accordingly. Maybe wait for @spockfish to have a setting for disable if thats going to be an option for turning off one or more of the 3 supported methods.

I think it’s probably just a one pager to cover all that. Just worth a mention as its noted as a feature for XL.

Must repeat - Great document :smiley:

1 Like
(David Toole) #16

It just keeps getting better and better. Thanks for all your hard work and dedication.

1 Like
(Nathan Wilkes) #17

@wizardofoz, this is no longer a true observation.

(Oscar Vromans) #18

With this version I have random reboots. I’m using the software since previous version with a raspberry pi 3 and a screen without any issues. Has anyone this problem too?

The system even reboots when I am not doing something with the system.

(Harry ten Berge) #19

Can you send feedback?

(Oscar Vromans) #20

What information do you need?