Stable release 3.094 (2021/04/07)

Hi all,

Time for another release!

Fairly typical ‘maintenance release’ with stuff all over the place. What stands out is optional volume normalisation when using Librespot (Spotify) and support for Allo’s dual band WiFi dongle.

Here’s the complete changelog:

  • NEW: support for Allo Boss2 DAC (audio only, no display support)
  • NEW: support for Allo’s dual band USB WiFi dongle (Comfast)
  • NEW: [RoPieeeXL] support for volume normalisation with Librespot
  • IMPROV: [RoPieeeXL] update Librespot
  • IMPROV: [RoPieeeXL] update upmpldcli
  • IMPROV: [RoPieeeXL] upmpdcli: disable AV endpoint when OpenHome is enabled, as this can confuse OpenHome renderers
  • FIX: setting webpage authentication does not work

As always: enjoy!

PS: I’m not going to release new images (lack of time).


Not sure how long this update should take but I selected update and restart about an hour ago and its still sat with a solid orange and green LED.

Its no issue I can reinstall the OS but it may be worthwhile holding off the update for the Allo Usbridge sig.

Took a few minutes on each of my two RPi4’s. I don’t have an Allo product. All is good. Thanks Harry.

Just pull the plug.

I did just that and was about to report back before you asked. Yes it worked a charm, no issues now. My regular Pi4 updated normally.

updated four Pi’s…

one of them shows 3.094 on the info page, but still shows 3.088 on the device page. (And yep, I’m looking at the correct one.)

Behavior is normal tho. Streams fine.

(Tried rebooting a few times, but no change.)

Screen Shot 2021-04-08 at 5.54.20 PM

Hi, I’m unsure where to leave feedback, so I’ll try here. My feedback key is 423b3486c071bcc6.

I noticed that the timezone used to interpret “Reboot Time” is UTC. It’s not a big deal, but from my perspective the Web UI should remind users which timezone is used. Since I didn’t know this at first, I thought I was experiencing an unreliable WiFi connection. Later I discovered the RPi was rebooting in prime-time due to the 9 hour mismatch with my timezone.

Yeah I hear you. It was first on the ‘general’ tab, but there it does not make much sense as the default setting is no reboot. I moved it to the display tab (as it makes sense for the clock), but I think it needs to be removed to the advanced tab.