Starlink (ISP) with ARC: CG-NAT Requires VPN Workaround (See Staff Post)

This situation, very very likely, holds true for T-Mobile 5G Home Internet as well. The same solution you implement for Starlink may very well positively impact T-Mobile’s service as well.

1 Like

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details


Connected Audio Devices

iPhone 13
Linn Selekt

Number of Tracks in Library


Description of Issue

Tried ARC today and worked very well on Wi-Fi. Tried it via 4G and all I got was a red box with Poor Connection written in. Had full 4G.


I’m still getting it. Have not yet managed any form of non Wi-Fi connection.

I’m not sure if this is relevant.

However I did discover that Starlink blocks all inbound ports and cannot be configured otherwise.

Does anyone have an answer for this?

Hi @Marcus_Adams1,

Thank you for your heroic display of patience while the support team worked to get through the queue of ARC-related threads after launch.

I’m noting your internet service provider is Starlink. Unfortunately, the port forwarding that supports mobile playback via ARC in Roon 2.0 can’t navigate the carrier-grade network address translation implemented by that provider. However, there are workarounds available. I’m going to merge your initial post into a thread where Starlink users have been posting solutions momentarily.

Seems to be unusable with Starlink.

@Marcus_Adams1, Starlink uses CG-NAT which prevents ARC from working over the Starlink network.

Unfortunately true. It effectively reverts to being as it always has been.

Sadly, where we live there are no other realistic internet services.

I’m in the same boat. I truly love Starlink compared to every other option I have tried in the middle of nowhere. Too bad Roon can’t devote the resources to solve it…I’m sure we are a very small subset of users in this situation. On the plus side we now have a crazy slow search in Roon with, from where I stand, even worse results. :clap: :clap: :clap:

Also a Starlink subscriber and ran into the same issue. It took a while to figure out that the issue was related to Starlink: Help needed to resolve: “doaction request return statuscode: UnknownError” - Support / Port Forwarding Help - Roon Labs Community

Like several Starlink users, I’ve been successful using ARC with a VPN - Recently however, Starlink has rolled out IPv6 in our region -

Should ARC be configurable without a VPN for Starlink customers where IPv6 has been implemented? I messed with a bit today but was unsuccessful …Is a static IP necessary for IPv6?

thanks - !

Roon arc does not do.ipv6 at the moment.

1 Like

that explains that then- thanks!

Hi everyone,

In case you hadn’t seen this post, we’re testing IPv6 compatibility in #earlyaccess: HELP MAKE ARC WORK FOR MORE USERS: Call for Volunteers with These Internet Service Providers to Join #EarlyAccess

If you believe your Starlink account has a static IPv6 external address assigned, you can download the Early Access builds here to try IPv6 compatibility:

However, before proceeding, please note that:

a) not all Starlink accounts will have a static IPv6 external address, as some still rely on dynamic IPv4 with CG-NAT
b) if you do have a static IPv6 external address on your Starlink account, then you will need a third-party router, as the Starlink-issued router reportedly does not support the firewall customization necessary for ARC to function with IPv6.

Please see here: Does Starlink Have Port Forwarding? - Starlink Hardware.

In many cases, if auto-configuration of ARC fails, you will need to add a firewall exception for the port listed in Roon → Settings → ARC in your router’s web administration page. In most routers, this will be under IPv6 or firewall settings.

My Roon subscription expires in 1 month and currently I cannot use Roon unless I’m using a device on the same local network as my ROCK (which isn’t often). Every possible solution is blocked by the very limited solutions Roon has provided:

  1. I can’t use Roon Arc in the normal way because I use Starlink which uses double-nat.
  2. I can’t run Roon Arc on my FiiO M11 Pro because it doesn’t have the correct version of Android
  3. I can’t use a product such as Tailscale because I have ROCK installed on a NUC 10 without any other OS.

So far here are the solutions I’ve been offered by Roon support:

  1. Upgrade to Starlink business for $500 per month
  2. Purchase another music player for over $1000
  3. Reconfigure my ROCK system into some type of OS installation which would completely remove the entire advantage I saw in Roon/ROCK when I decided to pay for this subscription.

I really love Roon but currently when I’m not home I must listen to my subscription services on Qobuz and Tidal or listen to my M11 with earbuds or Android Auto via Bluetooth. None of these solutions involves Roon so I’m not sure I’m getting any value by sticking around for another year to see if any of these problems will be solved. It would be great to hear something more than “we’re working on it”. Do you have any release dates yet that will allow your customers without standard Roon products to use Roon away from home?



Some thoughts:

  • Arc can work with double nat. Two-fold port forwarding is required, however.
  • Tailscale can be used also with Roon Rock. To this end, Tailscale needs to be installed on another device of the same network Roon Rock is connected with, e.g. a Synology Discstation or a Raspberry Pi with DietPi, and the the subnet router functionality of Tailscale is to enabled for this network.

Thank you for your reply. I love Tailscale but this doesn’t work with ROCK on a NUC since you can’t install it there. You would have to install something like Linux on the NUC and use a normal Roon OS Core. However I did find a VPN that works called PureVPN. They provide both a dedicated IP + Port Forwarding for Starlink users but unfortunately I still can’t get Roon ARC to connect.

As I mentioned, Tailscale works with Rock by means of a separate device using the subnet router function. However, it would be a substantial improvement of Rock, if Tailscale would be provided by Roon as an option.

I got Starlink working without a VPN and posted the instructions under tinkering if you’re interested.